Find the answer to your Linux question:
Results 1 to 6 of 6
I've modified the /etc/fstab file to automatically mount a second Windows hard drive at startup. However this has not worked exactly as I wanted it to, so I'd like some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Sheffield, UK
    Posts
    17

    /etc/fstab question


    I've modified the /etc/fstab file to automatically mount a second Windows hard drive at startup. However this has not worked exactly as I wanted it to, so I'd like some advice on adjusting the file.

    The hard drive has two partitions, both are which are NTFS. I've added the following two lines to the /etc/fstab file:

    /dev/hda1 /home/daley/Windows_C ntfs defaults 1 0
    /dev/hda5 /home/daley/Windows_D ntfs defaults 1 0


    These two partitions are then both automatically mounted at boot time. The problems however are that both are owned by root, and the permissions for both are rwx------.

    How should I change the fstab file so that the owner of these two mounted directories (and all their contents) is "daley", and the permissions for both (and contents) are rwxr-xr-x ?

    Thanks.

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    You can try the umask option.
    /dev/hda1 /home/daley/Windows_C ntfs,umask=022 defaults 1 0
    /dev/hda5 /home/daley/Windows_D ntfs,umask=022 defaults 1 0
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  3. #3
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    fyi, You can not write to NTFS without a 3rd-party program, which (IMO) is not super reliable.

  4. #4
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    That's true. Well, at least he can read the partition with any username

    Look at the captive-ntfs project.
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  5. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    9
    Unless you compile the kernel, you cannot use NTFS volumes with FC4 nor any FCx because the modules needed are not compiled with the kernel. I don't know why NTFS read-only access is not compiled as a module with the kernel and I'm disappointed that it is not. I have read posting that it is safe and I have used it without any problems. However, even though the source code that comes with NTFS support does contain an option to allow you to compile write capability, I have not used it because there are too many post indicating that it is dangerous.

    You will have to download the kernel source code (get a version from Fedora distributions) and all of the dependencies needed. The kernel source is not on the Fedora Core CDís. I think this is a mistake because everyone I know tweaks the kernel and now you have to go find it and download it, and install it Ė donít get me started. You will have to add the NTFS read (and if you need it write too) in the File System section (when runing the "make gconfig") to compile as a module and then compile and install the kernel to enable read or read/write access. Find more info on this forum or the www.fedoraformum.org or the Fedore Release notes about downloading, installing, and building a 2.6 kernel.

    When I need to share files between XP and Linux I create a FAT32 partition. This partition type is built into the kernel and you can read and write to this partition type from both operating systems. Only Windows NT does not support FAT32 in which case you will have to create a FAT partition.

    Another option is here:
    http://www.jankratochvil.net/project/captive

    I have not used it, but it looks promising.
    Hope this helps.

  6. #6
    Just Joined!
    Join Date
    Jan 2005
    Location
    Sheffield, UK
    Posts
    17
    Thanks guys.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •