Find the answer to your Linux question:
Results 1 to 7 of 7
i recently edited my xorg.conf file and need to boot to run level 3 (init 3). How do i do this from grub or as Linux is booting?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast flipjargendy's Avatar
    Join Date
    Aug 2004
    Location
    Xanadu, Titan, Saturn
    Posts
    612

    Booting to Run Level 3 from grub?


    i recently edited my xorg.conf file and need to boot to run level 3 (init 3). How do i do this from grub or as Linux is booting?

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Location
    Bulgaria, Peshtera
    Posts
    66
    well I assume you need x not to be running so I'd suggest editing the boot arguments in grub. Remove rhgb(red hat graphical boot) and you should get the standart "machine@something login:". Hey, it's worth the try .You can always edit the grub lines so you shouldn't have a problem.

    ...Pardon my tone, haven't had my coffee today

  3. #3
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Do you want this to be permanent, booting into runlevel 3, or is this just so you don't have X running.

    If the latter, to kill X, when you are in the GUI, hit Ctrl + Alt + Backspace. Xis killed.

    If you want to make this a permanent change, you will need to edit /etc/inittab.
    Code:
    su > root password
    nano -w  /etc/inittab
    Change that 5 in the default line to a 3

    Then hit Ctrl + X and save your work
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: Booting to Run Level 3 from grub?

    Quote Originally Posted by flipjargendy
    ...need to boot to run level 3 (init 3). How do i do this from grub or as Linux is booting?
    When Grub comes up, you should have an option to get the Grub command line. From there you should see instructions for editing Grub. Any editing done that way is not permanent: it's only for that session, so you can't screw anything up. Anyways, find the "kernel" line for the Grub menu title that you want to boot and add the word "single" to the end of that line to boot in single user mode or runlevel 1. Once you are in, you should be able to use the command 'init 3' to change into runlevel 3.
    /IMHO
    //got nothin'
    ///this use to look better

  5. #5
    Linux Enthusiast flipjargendy's Avatar
    Join Date
    Aug 2004
    Location
    Xanadu, Titan, Saturn
    Posts
    612
    Thanks for the help guys, it was my XORG.conf file effecting the kernel configuration at boot up. i just deleted the things i added to my XORG file and will have to deal with the changes i made later. i am trying to get my screen to look right, i've got a 16:10 display ratio and everything looks wide. i'd take any advice on that if anyone's got any

  6. #6
    Just Joined!
    Join Date
    Nov 2009
    Posts
    2
    Quote Originally Posted by flipjargendy View Post
    Thanks for the help guys, it was my XORG.conf file effecting the kernel configuration at boot up. i just deleted the things i added to my XORG file and will have to deal with the changes i made later. i am trying to get my screen to look right, i've got a 16:10 display ratio and everything looks wide. i'd take any advice on that if anyone's got any
    I had a issue where i installed a bad driver on a Suse distro that would just totally wipe the video out. ctrl+alt+1 thru 6 didn't do squat just a black screen.
    I had to boot with System Rescue disc and than mount the partition and than edit the inittab.

  7. #7
    Just Joined!
    Join Date
    Nov 2009
    Posts
    2
    thats ctrl+alt+f1 and ctrl+alt+backspace didn't work either. Seems the GPU just said goodbye cruel world and stops working because even the shut down sequence gracefully (using ctrl+alt+del after ctrl+alt+f1) the screen remains black until the bios posts on reboot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •