Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
I have got 3 OSs on my laptop Latitude Dell D600 (Windows , FC3, Solaris 10) I have got no problem to boot in any of these 3 OSs. After ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2002
    Posts
    139

    Repair file system


    I have got 3 OSs on my laptop Latitude Dell D600 (Windows , FC3, Solaris 10)

    I have got no problem to boot in any of these 3 OSs.

    After while I tried to boot into linux I received this error message :

    Run 'setenforce 1' to reenable.

    Give root password for maintenance (or type Control-D to continue):

    Repair file system1#




    After I spent one hour of googling I found this :

    ((If the system crashes (due to power outage etc...) then upon boot the system will check if the disk was unmounted cleanly. If not you may get the following message:
    Unexpected inconsistency; Run fsck Manually
    ...
    *** An error occurred during the file system check.
    *** Dropping you to a shell; the system will reboot

    Give root password for maintenance
    (or type Control-D for normal startup):
    At this point enter the root password then run fsck:
    (repair file system) 1# fsck -A -y

    ***** FILE SYSTEM WAS MODIFIED *****
    (repair file system) 2# exit ))

    The link for above is this :

    http://www.yolinux.com/TUTORIALS/Lin...lSysAdmin.html


    I run the command : fsck -A -y then--------According to what the link advised

    I rebooted the laptop, I received this error message:

    mkrootdedv: label / not found
    mount: error 2 mounting ext3
    mount: error 2 mounting none
    switchroot: mount failed:22
    umount /initrd/dev failed:2
    kernel panic. not syncing
    Attempted to kinll init!

    What should I do to solve this issue?

  2. #2
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    What does your /etc/fstab look like?

    Just so I didn't miss anything, your / filesystem was not mounted when you ran fsck, correct? (I know you ran it in single user mode; I just want to be sure.)

  3. #3
    Linux Newbie
    Join Date
    Nov 2002
    Posts
    139
    I booted my linux box through CD1 and then "F5" for rescue mode, and then command : "linux rescue", and then I tried vi /etc/fstab...

    I could not find file fstab,,,,,,,,,,,,.

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by zillah
    I could not find file fstab,,,,,,,,,,,,.
    You first need to mount the partition that has your root ( / ) directory on it:
    Code:
    Repair file system1#  mount /dev/hda2 /mnt/    <-assuming root is on hda2
    Repair file system2#  vi /etc/fstab    <-assuming you want to edit /etc/fstab&#58; if you just want to look at /etc/fstab&#58;
    Repair file system2#  more /etc/fstab
    But your /etc/fstab is probably okay. Try rescue mode again and run fsck without switches. The man pages for fsck show that using the '-A' switch requires fsck to be able to read /etc/fstab for which, the root partition would need to be mounted. So the -A switch is no good for fscking the root partition. I'm not sure where the -y switch came from. Bottom line:
    Code:
    Repair file system1#  fdisk -l    <-to see what partitions you have and which are Linux &#40;in case you haven't kept good notes....&#41;
    Repair file system2#  fsck /dev/hda2   <-or whatever hdxx for each of your Linux partitions.
    /IMHO
    //got nothin'
    ///this use to look better

  5. #5
    Linux Newbie
    Join Date
    Nov 2002
    Posts
    139
    Hi drakebasher

    Nice to hear your comment, I will try what you suggested.

  6. #6
    Linux Newbie
    Join Date
    Nov 2002
    Posts
    139
    This is what happend to me:

    1- Throught "My Computer" icon (windows OS), I can see (which I should not) the partition that is belong to linux (/usr)!!! but I can not (It should be like this) see the other Linux partitons /, /boot, /home.

    2- When I used (windows OS) the utility called "explore2fs" I was able to see (/, /boot, /home) but not /usr.!!!!


    3- I used FC3 CD1 and in the rescue mode, I found (fdisk -l) that the /usr partition is still type "ext3" with id 83.

    Now the problem when I boot into FC3, I received this erro message :

    fsck.ext3: Unable to resolve 'LABEL=/usr1' FAILED.


    *** An error occurred during the file system check.
    *** Dropping you to a shell; the system will reboot.
    *** When you leave the shell.
    *** Warning -- SELinux is active.
    *** Disabling security enforcement for system recovery.
    *** Run 'setenforce 1' to reenable.

    Give root password for maintenance
    (or type Control-D for normal startup):

    This is not the first time I am receiving this error message, I experienced the same problem before (at that time I installed every thing again from scratch).






    These are some troubleshooting that I have done:

    What I did:

    I checked fstab : vi /etc/fstab

    1- I changed: LABEL=/usr1 to LABEL=/usr (origin name)-------------> it did not work.

    2- I changed : LABEL=/usr1 to /dev/hda6 (my case '/usr' file system is on hda6 partition , and file system type ext3)----> it did not work also.

    3- I run : e2fsck -f /dev/hda6

    I received this message:

    " e2fsck 1.35 (28-Feb-2004)
    Couldn't find ext2 superblock, trying backup blocks...
    fsck.ext3: Bad magic number in super-block while trying to open /dev/hda6

    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>----------- ".


    4- I run e2label /dev/hda6

    I received this message:

    " e2label: Bad magic number in super-block while trying to open /dev/hda6
    Couldn't find valid filesystem superblock ".








    If it sounds like corrupted,at this point, I should consider a fresh installation.
    As you know I have got 3 OSs, and I am scared if I reinstall FC3, I won't be able to boot solaris OS.

  7. #7
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by zillah
    As you know I have got 3 OSs, and I am scared if I reinstall FC3, I won't be able to boot solaris OS.
    If you decide to reinstall, if you don't already have a /boot partition, you should create one. That would make this kind of situation much easier. Write down, print or copy to floppy your bootloader scripts. And make a Grub boot floppy for security.

    Quote Originally Posted by fsck.ext3
    *** Warning -- SELinux is active.
    I think SELinux, in FC3, is still considered kind of unstable/experimental. I don't know if it's at all related to your present problems, but I think knowledgeable users would recommend to have it turned off with "warn only".

    Quote Originally Posted by You
    I changed : LABEL=/usr1 to /dev/hda6
    That's the right thing. That "LABEL" stuff seems to be more hassle than anything for most users.

    Quote Originally Posted by Finally, e2fsck -f /dev/hda6
    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>-----------
    Do some research on that. There are alternate superblocks written to defined locations to serve as backup to the primary superblock. Sounds like this is your best bet for recovery.
    /IMHO
    //got nothin'
    ///this use to look better

  8. #8
    Linux Newbie
    Join Date
    Nov 2002
    Posts
    139
    If you decide to reinstall, if you don't already have a /boot partition, you should create one. That would make this kind of situation much easier.
    I have /boot partition.

    But what did you meen if I do not have one, I should create one ? As you know I do not want to mess up the OSs,,,where should I create /boot ?

    Write down, print or copy to floppy your bootloader scripts. And make a Grub boot floppy for security.
    Did you meen the /etc/grub.conf ?

    but I think knowledgeable users would recommend to have it turned off with "warn only".
    How to turn it off?

  9. #9
    Linux User
    Join Date
    Aug 2005
    Location
    Peterborough, UK
    Posts
    379
    Quote Originally Posted by zillah
    but I think knowledgeable users would recommend to have it turned off with "warn only".
    How to turn it off?
    In X, run:
    Code:
    system-config-securitylevel
    If you're using KDE, it's under 'System Settings > Security Level' on the menu.
    \"I am, after all,\" said Pooh, \"a bear of very little brain.\"
    MY PC: Athlon XP64 3000+ on a Asus K8V-X mobo w/1GB of non-descript RAM. AGP - GeForce 2 MX400. PCI - Creative Live! 5.1 soundcard. 140 GB and 120 GB SATA WD drives.

  10. #10
    Linux Newbie
    Join Date
    Nov 2002
    Posts
    139
    If you're using KDE, it's under 'System Settings > Security Level' on the menu.
    I can not access the KDE.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •