Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Help - Cannot Installaer Windows Installer Using Wine Tools - Insufficient Priviliges Errors


    Hi Guys,

    I am trying to install MSN Messenger so I can use it under Fedora running Wine. The reason why I need MSN Messenger is because at work we run Live Communication Server 2005 which is based on the SIP protocol. So, basically, they want to disable Exchange MSN messenger. Gaim cannot connect to Live Comm Server (I have tried) without any success.

    Everytime I attempt to install the Microsoft Windows Installer program using "Wine Tools" I receive the following error:

    "The installer has insufficient priviliges to modify this file: c:\Config.Msi\<filename>.rbf" message

    Can anyone offer some assistance as to how to get around this problem. I have attempted to give the account all available permissions - however, the error still shows.

    Thank you for any assistance,
    Edgar

  2. #2
    Try running the installer as root. (either log in as root, or type su and enter your root password when prompted)
    N3WO

    There are 10 types of people; those who count in binary and those who don\'t...

  3. #3

    Windows INstaller error

    Thank you for the response. So, you would type sudo wine <file name>.exe? I thought you couldn't run wine as a root?

    I will give it a try. Thank you!

  4. $spacer_open
    $spacer_close
  5. #4
    I tried running Wine using su, and it worked fine. I've had no success using sudo; try using
    Code:
    $ su
    and enter the root password when prompted. After doing that, you have root priveleges. Just type wine <file name>.exe
    N3WO

    There are 10 types of people; those who count in binary and those who don\'t...

  6. #5

    Thanks...almost there..One more thing

    -->
    Great! It worked. Now I have windows installer finally installed...Thanks alot.

    I have tried installing the messenger.msi using the recommended command:

    "wine msiexec /i messenger-1.msi" The following error shows. By the way, I had to edit the wine config file . I have changed the following line under the [Version] header:
    'Windows"="Windows98" to "Windows"=Windowsxp" and also tried "Win2k" without any results. I am including the error message genrated by wine after using the above wine command.

    fixme:advapi:ReportEventW (0xcafe4242,0x0002,0x0000,0x000003f7,(nil),0x0006, 0x00000000,0x77e404f8,(nil)): stub
    fixme:advapieregisterEventSource (0xcafe4242) stub
    The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

    As always, any help would be greatly appreciated.
    Ed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •