Find the answer to your Linux question:
Results 1 to 3 of 3
when i try to install vlc, it does this: a52dec-0.7.4-7.1.fc3.fr.i386.rpm libdvdcss-1.2.8-4.1.fc3.fr.i386.rpm lirc-0.6.6-4.1.fc3.fr.i386.rpm aalib-1.4.0-5.1.fc3.fr.i386.rpm libdvdnav-0.1.10-2.1.fc3.fr.i386.rpm mpeg2dec-0.4.1-0.20040610.2.1.fc3.fr.i386.rpm bob libdvdread-0.9.4-5.1.fc3.fr.i386.rpm openslp-1.2.0-1.i386.rpm cdinfo-0.71-0.i386.rpm libid3tag-0.15.1b-3.1.fc3.fr.i386.rpm vcdimager-0.7.20-1.1.vlc.i386.rpm faac-1.24-1.1.fc3.fr.i386.rpm libmad-0.15.1b-3.1.fc3.fr.i386.rpm vcdimager-0.7.20-3.i386.rpm faad2-2.0-2.20040923.1.fc3.fr.i386.rpm libmodplug-0.7-2vlc.i386.rpm vcdimager-libvcd-0.7.20-1.1.vlc.i386.rpm imlib2-1.1.2-2.1.fc3.fr.i386.rpm libmodplug-0.7-3vlc.i386.rpm vlc-0.8.1-1.i386.rpm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Location
    The Depths of Angband
    Posts
    51

    Exclamation unable to install vlc


    when i try to install vlc, it does this:

    a52dec-0.7.4-7.1.fc3.fr.i386.rpm libdvdcss-1.2.8-4.1.fc3.fr.i386.rpm lirc-0.6.6-4.1.fc3.fr.i386.rpm
    aalib-1.4.0-5.1.fc3.fr.i386.rpm libdvdnav-0.1.10-2.1.fc3.fr.i386.rpm mpeg2dec-0.4.1-0.20040610.2.1.fc3.fr.i386.rpm
    bob libdvdread-0.9.4-5.1.fc3.fr.i386.rpm openslp-1.2.0-1.i386.rpm
    cdinfo-0.71-0.i386.rpm libid3tag-0.15.1b-3.1.fc3.fr.i386.rpm vcdimager-0.7.20-1.1.vlc.i386.rpm
    faac-1.24-1.1.fc3.fr.i386.rpm libmad-0.15.1b-3.1.fc3.fr.i386.rpm vcdimager-0.7.20-3.i386.rpm
    faad2-2.0-2.20040923.1.fc3.fr.i386.rpm libmodplug-0.7-2vlc.i386.rpm vcdimager-libvcd-0.7.20-1.1.vlc.i386.rpm
    imlib2-1.1.2-2.1.fc3.fr.i386.rpm libmodplug-0.7-3vlc.i386.rpm vlc-0.8.1-1.i386.rpm
    lame-3.96.1-2.1.fc3.fr.i386.rpm libpostproc-1.0-0.11.pre5.1.fc2.fr.i386.rpm wxGTK-2.4.2-5.1.fc3.fr.i386.rpm
    libcddb-0.9.6-1.i386.rpm libpostproc-1.0-0.12.20041025.1.fc3.fr.i386.rpm wxGTK-gl-2.4.2-5.1.fc3.fr.i386.rpm
    libcdio-0.71-0.i386.rpm libtar-1.2.11-1.i386.rpm wxGTK-stc-2.4.2-5.1.fc3.fr.i386.rpm
    libdvbpsi-0.1.4-1.1.fc3.fr.i386.rpm libvcd-0.7.20-3.i386.rpm wxGTK-xrc-2.4.2-5.1.fc3.fr.i386.rpm
    [root@localhost vlc]# yum install vlc-0.8.1-1.i386.rpm
    Loading "installonlyn" plugin
    Setting up Install Process
    Setting up repositories
    core [1/4]
    macromedia [2/4]
    extras [3/4]
    updates [4/4]
    Reading repository metadata in from local files
    Parsing package install arguments
    Examining vlc-0.8.1-1.i386.rpm: vlc - 0.8.1-1.i386
    Marking vlc-0.8.1-1.i386.rpm to be installed
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package vlc.i386 0:0.8.1-1 set to be updated
    --> Running transaction check
    --> Processing Dependency: libdvdnav.so.4 for package: vlc
    --> Processing Dependency: libdvbpsi.so.3 for package: vlc
    --> Processing Dependency: libfaad.so.0 for package: vlc
    --> Processing Dependency: libdbus-1.so.0 for package: vlc
    --> Processing Dependency: wxGTK >= 2.4.2 for package: vlc
    --> Processing Dependency: libmpeg2.so.0 for package: vlc
    --> Processing Dependency: libaa.so.1 for package: vlc
    --> Processing Dependency: libhal.so.0 for package: vlc
    --> Processing Dependency: libwx_gtk-2.4.so.0(WXGTK_2.4) for package: vlc
    --> Processing Dependency: libid3tag.so.0 for package: vlc
    --> Processing Dependency: libmad.so.0 for package: vlc
    --> Processing Dependency: libfaac.so.0 for package: vlc
    --> Processing Dependency: a52dec for package: vlc
    --> Processing Dependency: libmad >= 0.15.0b for package: vlc
    --> Processing Dependency: libFLAC.so.4 for package: vlc
    --> Processing Dependency: faad2 >= 2.0 for package: vlc
    --> Processing Dependency: libwx_gtk-2.4.so.0 for package: vlc
    --> Processing Dependency: libdvdread >= 0.9.4 for package: vlc
    --> Processing Dependency: libdvdcss >= 1.2.8 for package: vlc
    --> Processing Dependency: libdvdread.so.3 for package: vlc
    --> Processing Dependency: aalib >= 1.4 for package: vlc
    --> Processing Dependency: faac for package: vlc
    --> Processing Dependency: liba52.so.0 for package: vlc
    --> Processing Dependency: libdvbpsi >= 0.1.3 for package: vlc
    --> Processing Dependency: libcddb.so.0 for package: vlc
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for wxGTK to pack into transaction set.
    http://www.gtlib.cc.gatech.edu/pub/f....fc5.i386.rpm: [Errno 4] IOError: <urlopen error (111, 'Connection refused')>
    Trying other mirror.
    wxGTK-2.6.3-2.6.3.2.1.fc5 100% |=========================| 0 B 00:00
    ftp://mirror.newnanutilities.org/pub....fc5.i386.rpm: [Errno -1] Header is not complete.
    Trying other mirror.
    wxGTK-2.6.3-2.6.3.2.1.fc5 100% |=========================| 22 kB 00:00
    ---> Package wxGTK.i386 0:2.6.3-2.6.3.2.1.fc5 set to be updated
    ---> Downloading header for aalib to pack into transaction set.
    aalib-1.4.0-0.rc5.7.i386. 100% |=========================| 5.9 kB 00:00
    ---> Package aalib.i386 0:1.4.0-0.rc5.7 set to be updated
    ---> Downloading header for libid3tag to pack into transaction set.
    libid3tag-0.15.1b-2.fc5.i 100% |=========================| 4.7 kB 00:00
    ---> Package libid3tag.i386 0:0.15.1b-2.fc5 set to be updated
    ---> Downloading header for compat-wxGTK to pack into transaction set.
    compat-wxGTK-2.4.2-17.fc5 100% |=========================| 6.5 kB 00:00
    ---> Package compat-wxGTK.i386 0:2.4.2-17.fc5 set to be updated
    --> Running transaction check
    --> Processing Dependency: libhal.so.0 for package: vlc
    --> Processing Dependency: compat-wxGTK-common = 2.4.2-17.fc5 for package: compat-wxGTK
    --> Processing Dependency: libFLAC.so.4 for package: vlc
    --> Processing Dependency: libdvdnav.so.4 for package: vlc
    --> Processing Dependency: faad2 >= 2.0 for package: vlc
    --> Processing Dependency: libdvbpsi.so.3 for package: vlc
    --> Processing Dependency: libfaad.so.0 for package: vlc
    --> Processing Dependency: libdvdread >= 0.9.4 for package: vlc
    --> Processing Dependency: libdvdcss >= 1.2.8 for package: vlc
    --> Processing Dependency: libdbus-1.so.0 for package: vlc
    --> Processing Dependency: libmad >= 0.15.0b for package: vlc
    --> Processing Dependency: libdvdread.so.3 for package: vlc
    --> Processing Dependency: faac for package: vlc
    --> Processing Dependency: libmad.so.0 for package: vlc
    --> Processing Dependency: liba52.so.0 for package: vlc
    --> Processing Dependency: a52dec for package: vlc
    --> Processing Dependency: libmpeg2.so.0 for package: vlc
    --> Processing Dependency: libfaac.so.0 for package: vlc
    --> Processing Dependency: libdvbpsi >= 0.1.3 for package: vlc
    --> Processing Dependency: libcddb.so.0 for package: vlc
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for compat-wxGTK-common to pack into transaction set.
    compat-wxGTK-common-2.4.2 100% |=========================| 11 kB 00:00
    ---> Package compat-wxGTK-common.i386 0:2.4.2-17.fc5 set to be updated
    --> Running transaction check
    --> Processing Dependency: libhal.so.0 for package: vlc
    --> Processing Dependency: libFLAC.so.4 for package: vlc
    --> Processing Dependency: libdvdnav.so.4 for package: vlc
    --> Processing Dependency: faad2 >= 2.0 for package: vlc
    --> Processing Dependency: libdvbpsi.so.3 for package: vlc
    --> Processing Dependency: libfaad.so.0 for package: vlc
    --> Processing Dependency: libdvdread >= 0.9.4 for package: vlc
    --> Processing Dependency: libdvdcss >= 1.2.8 for package: vlc
    --> Processing Dependency: libdbus-1.so.0 for package: vlc
    --> Processing Dependency: libmad >= 0.15.0b for package: vlc
    --> Processing Dependency: libdvdread.so.3 for package: vlc
    --> Processing Dependency: faac for package: vlc
    --> Processing Dependency: libmad.so.0 for package: vlc
    --> Processing Dependency: liba52.so.0 for package: vlc
    --> Processing Dependency: a52dec for package: vlc
    --> Processing Dependency: libmpeg2.so.0 for package: vlc
    --> Processing Dependency: libfaac.so.0 for package: vlc
    --> Processing Dependency: libdvbpsi >= 0.1.3 for package: vlc
    --> Processing Dependency: libcddb.so.0 for package: vlc
    --> Finished Dependency Resolution
    Error: Missing Dependency: libdvdnav.so.4 is needed by package vlc
    Error: Missing Dependency: libdvbpsi.so.3 is needed by package vlc
    Error: Missing Dependency: libfaad.so.0 is needed by package vlc
    Error: Missing Dependency: libdbus-1.so.0 is needed by package vlc
    Error: Missing Dependency: libmpeg2.so.0 is needed by package vlc
    Error: Missing Dependency: libhal.so.0 is needed by package vlc
    Error: Missing Dependency: libmad.so.0 is needed by package vlc
    Error: Missing Dependency: libfaac.so.0 is needed by package vlc
    Error: Missing Dependency: a52dec is needed by package vlc
    Error: Missing Dependency: libmad >= 0.15.0b is needed by package vlc
    Error: Missing Dependency: libFLAC.so.4 is needed by package vlc
    Error: Missing Dependency: faad2 >= 2.0 is needed by package vlc
    Error: Missing Dependency: libdvdread >= 0.9.4 is needed by package vlc
    Error: Missing Dependency: libdvdcss >= 1.2.8 is needed by package vlc
    Error: Missing Dependency: libdvdread.so.3 is needed by package vlc
    Error: Missing Dependency: faac is needed by package vlc
    Error: Missing Dependency: liba52.so.0 is needed by package vlc
    Error: Missing Dependency: libdvbpsi >= 0.1.3 is needed by package vlc
    Error: Missing Dependency: libcddb.so.0 is needed by package vlc
    [root@localhost vlc]#

    as you can see at the top, all the .rpm's are there, but they wont work. (i posted another
    thread showing what happened if i tried to install a single .rpm that is needed for it)

  2. #2
    Linux Enthusiast
    Join Date
    Aug 2005
    Location
    Hell
    Posts
    514
    Yum tries to resolve dependencies from its repositories; and you didn't add repositories that have those things. Instead of downloading a bunch of RPMs, the easiest thing is instead to add the appropriate Yum repository, and then just do "yum install vlc"

  3. #3
    Linux Enthusiast
    Join Date
    Aug 2005
    Location
    Hell
    Posts
    514
    I suggest that you add Livna and then do "yum install vlc".

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •