Find the answer to your Linux question:
Results 1 to 7 of 7
hi, wat should i modify or add so tht i can boot into single user mode....am using Redhat 9.0..Suse has "failsafe" option which can be selected during the start of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    36

    How to enter in to single user mode from Grub???


    hi,
    wat should i modify or add so tht i can boot into single user mode....am using Redhat 9.0..Suse has "failsafe" option which can be selected during the start of boot procees itself....however i observed tht we cannot choose failsafe option untill we get to the login screen incase of Redhat.....i have read somwhere we can edit some options via grub to boot into single user mode.....does any one know wat to edit......or is there any other way around....to get into single user mode.....

    any help will be appreciated....

    Thanks
    Greenday

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,845
    At the grub boot menu, select the option that lets you edit the kernel parameters. Add either a '1' or 'single' to the end of the kernel parameters, then continue booting up.

    Dont get paranoid about this, not knowing it doesn't make you an American Idiot...
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    36
    Quote Originally Posted by Roxoff
    At the grub boot menu, select the option that lets you edit the kernel parameters. Add either a '1' or 'single' to the end of the kernel parameters, then continue booting up.




    Dont get paranoid about this, not knowing it doesn't make you an American Idiot...
    thanks for reply,

    these r the options in grub menu

    e- edit commands before booting,
    c- command line,
    a- modify the kernel arguments before booting.

    so i selected 'e'.....it took me to one more menu which has three options

    root (hd0,0)
    kernel /vmlinuz-2.4.20-6 ro root=LABEL=/
    initrd /initrd-2.4.20-6.img

    which of the following should i add the "single' or '1'...i tried with the seond one ..doesnt seem to work.....am i doing something wrong


    btw goodone on "american idiot" ha ha

  4. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,845
    Quote Originally Posted by Greenday
    thanks for reply,

    these r the options in grub menu

    e- edit commands before booting,
    c- command line,
    a- modify the kernel arguments before booting.

    so i selected 'e'.....it took me to one more menu which has three options

    root (hd0,0)
    kernel /vmlinuz-2.4.20-6 ro root=LABEL=/
    initrd /initrd-2.4.20-6.img

    which of the following should i add the "single' or '1'...i tried with the seond one ..doesnt seem to work.....am i doing something wrong


    btw goodone on "american idiot" ha ha
    It's option A, I believe. But try it; if it's wrong, reboot with the reset button!

    ps. Green Day are one of my favourite bands...
    Linux user #126863 - see http://linuxcounter.net/

  5. #5
    Just Joined!
    Join Date
    Feb 2006
    Posts
    36
    Quote Originally Posted by Roxoff
    It's option A, I believe. But try it; if it's wrong, reboot with the reset button!

    ps. Green Day are one of my favourite bands...

    Thanks again....

    I did add '1' to the first option "root(hd0,0)1"....it boots but it is again entering runlevel 5 automaticallly even after this.....any idea y this is happening even after adding '1'.....

  6. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,845
    It's probably one of the others then... but what you do is when the boot menu appears, select the right option and you'll get to edit the command line parameters, they'll look a bit like the kernel line from grub.conf, just stick a 1 at the end of that (dont edit grub.conf btw, unless you always want to boot up in single user mode...)
    Linux user #126863 - see http://linuxcounter.net/

  7. #7
    Just Joined!
    Join Date
    Feb 2006
    Posts
    36
    Quote Originally Posted by Roxoff
    It's probably one of the others then... but what you do is when the boot menu appears, select the right option and you'll get to edit the command line parameters, they'll look a bit like the kernel line from grub.conf, just stick a 1 at the end of that (dont edit grub.conf btw, unless you always want to boot up in single user mode...)

    thanks for all your help...its the second option.....a space have to be there between the '/' and the '1' we add.....i wasn't giving the space.....it works now....

    thanks again...

    Greenday

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •