Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 28
Originally Posted by techieMoe Ok. Try and get it set up using your /etc/fstab. that's the problem, I don't know how to use /etc/fstab Just curious, for better linux users, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Dec 2005
    Posts
    14

    Quote Originally Posted by techieMoe
    Ok. Try and get it set up using your /etc/fstab.
    that's the problem, I don't know how to use /etc/fstab

    Just curious, for better linux users, is it better to auto mount your CD drives or is it still best practice to do manual mounts and umounts?

  2. #12
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    try this:

    to find out your cdrom dev point

    dmesg | grep hd
    [look for your cdrom under something like hdc or hdd or hdb]

    then edit /etc/fstab with a text editor like emacs, vi, vim, nano, kate etc...

    add a line like this:
    Code:
    /dev/hdc                /media/cdrom      iso9660         ro,user  0 0
    then as root

    Code:
    mkdir /media/cdrom
    then as root

    Code:
    mount /dev/hdc /media/cdrom
    note: I'm using /dev/hdc but you need to use whatever the dmesg | grep hd told you was the device point for your cdrom drive.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #13
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by charlesachang
    that's the problem, I don't know how to use /etc/fstab
    Hang in there. I haven't done this in a while, but I'm sure someone can give you a step-by-step.

    Just curious, for better linux users, is it better to auto mount your CD drives or is it still best practice to do manual mounts and umounts?
    What's "better" depends entirely on you. Do you want to manually mount/unmount CDROMs every time you insert one? Do you have some other reason for not wanting CDROMs to automatically mount? Unlike Microsoft Windows, you have very little chance of any malicious code executing when your CD automounts. It's just personal preference, really.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  4. #14
    Just Joined!
    Join Date
    Dec 2005
    Posts
    14
    Thanks guys for your help. Editing the fstab seemed to work.

  5. #15
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    no problem glad it worked for you.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  6. #16
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4
    dear i tried the steps above

    [root@myeasyroots dev]# dmesg | grep hdc
    [root@myeasyroots dev]#


    i got nothing

    and i edited the fstab file by adding the line
    /dev/hdc /media/cdrom iso9660 ro,user 0 0

    than

    mkdir /media/cdrom

    than

    [root@myeasyroots dev]# mount /dev/hdc /media/cdrom
    mount: special device /dev/hdc does not exist


    so anyway that i can access my cdrom with or what is the problem?

  7. #17
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by jghao
    dear i tried the steps above

    [root@myeasyroots dev]# dmesg | grep hdc
    [root@myeasyroots dev]#


    i got nothing

    and i edited the fstab file by adding the line
    /dev/hdc /media/cdrom iso9660 ro,user 0 0

    than

    mkdir /media/cdrom

    than

    [root@myeasyroots dev]# mount /dev/hdc /media/cdrom
    mount: special device /dev/hdc does not exist


    so anyway that i can access my cdrom with or what is the problem?
    You're almost there jghao,
    Spencer was telling you to try dmesg | grep hd and not dmesg | grep hdc
    you'll see something like this
    Code:
    dmesg | grep hd
        ide0: BM-DMA at 0x10a0-0x10a7, BIOS settings: hda:DMA, hdb:DMA
        ide1: BM-DMA at 0x10a8-0x10af, BIOS settings: hdc:DMA, hdd:pio
    hda: Maxtor 4D040H2, ATA DISK drive
    hdb: Maxtor 90340D2, ATA DISK drive
    hdc: CW058D ATAPI CD-R/RW, ATAPI CD/DVD-ROM drive
    hdd: LITE-ON LTR-16102B, ATAPI CD/DVD-ROM drive
    Since I have two CDROM's I can use /dev/hdc or /dev/hdd
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #18
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4
    dear
    well here what i got

    [root@myeasyroots ~]# dmesg | grep hd
    [root@myeasyroots ~]#


    so nothing changed i tried it b4

  9. #19
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    You could always look at
    Code:
    cat /var/log/messages
    and look for it there. Let us know what it is or post it here.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #20
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4
    well it is empty

    [root@myeasyroots ~]# more /var/log/messages
    [root@myeasyroots ~]# syslogd
    [root@myeasyroots ~]# more /var/log/messages
    Sep 13 17:53:49 myeasyroots syslogd 1.4.1: restart.


    so what can i do now?

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •