Find the answer to your Linux question:
Results 1 to 10 of 10
Im running a linux machine as a samba file server, but wanted to also run it as a web server. the httpd service ran fine the first time but wont ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4

    httpd wont start


    Im running a linux machine as a samba file server, but wanted to also run it as a web server. the httpd service ran fine the first time but wont restart now.
    when i try to start it in the terminal i get the error:

    [Kevin@server ~]$ /etc/init.d/httpd start
    Starting httpd: httpd: Syntax error on line 188 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_access.so into server: /etc/httpd/modules/mod_access.so: cannot open shared object file: No such file or directory
    [FAILED]

    Does this mean anything to anybody?

    im really new to linux and still getting to know a lot of this.

  2. #2
    Just Joined!
    Join Date
    Oct 2005
    Posts
    9
    Did you accidentally modify the file?

    Open the config file /etc/httpd/conf/httpd.conf and check the lines around 188 for errors (inadvertent punctuation and things like that).

    If everything seems fine, and the error persists, just comment out the line that says "LoadModule ... mod_access". I'm not sure what this module does; if everything works without it, then your problem is solved, at least for now.

    --
    CC

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    I had never even seen the file till it gave me that error message, since i posted i had a look at the file and couldnt see anything wrong with it, but since im new to this im not sure what to look for.

    Line 188:

    LoadModule auth_module modules/mod_auth.so

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2005
    Posts
    9
    Did you try commenting out the line?

    Change -

    Code:
    LoadModule auth_module modules/mod_auth.so
    To -

    Code:
    # LoadModule auth_module modules/mod_auth.so
    See if this works. If it doesn't, then change it back and post your httpd.conf file as an attachment. I'll try to figure out what's wrong.

    --
    CC

  6. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    tried and failed, it just gave an error for line 189

    i had to change .conf to .txt to get it to upload.
    Attached Files Attached Files

  7. #6
    Just Joined!
    Join Date
    Oct 2005
    Posts
    9
    Hi,

    I tried your httpd.conf file, and it just doesn't work. There are references to a lot many modules that simply don't exist in my installation. Which version of httpd is this, and where did you install it from? Which OS (flavor and version) are you running?

    In any case, your config file is trying to load modules that aren't there, so try loading all the existing modules.

    (1) Check that the /etc/httpd/modules directory exists and there are mod_*.so files there.
    (2) Open a shell and execute this script -
    Code:
    cd /etc/httpd ; for x in modules/mod_*.so ; do y="${x#modules/mod_}" ; y="${y%.so}_module" ; echo "LoadModule ${y} ${x}" >> /etc/httpd/mods ; done
    (3) A file should be created at /etc/httpd/mods containing LoadModule directives; replace the LoadModules lines in the httpd.conf file with the contents of this file
    (4) Try starting httpd, and if it fails on any module(s), comment it out.

    I'm no expert on httpd, so cross your fingers.

  8. #7
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    I got httpd of the installation disk, I installed when installing the OS, im using Fedora Core 5.

    It exists with 67 mod_*.so files
    I had to # 6 lines then got this

    [Kevin@server ~]$ /etc/init.d/httpd start
    Starting httpd: [Thu Jul 13 11:17:23 2006] [warn] module perl_module is already loaded, skipping
    [Thu Jul 13 11:17:24 2006] [warn] module python_module is already loaded, skipping
    [Thu Jul 13 11:17:24 2006] [warn] module ssl_module is already loaded, skipping
    (13)Permission denied: make_sock: could not bind to address [::]:80
    (13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    [FAILED]

  9. #8
    Just Joined!
    Join Date
    Oct 2005
    Posts
    9
    I just noticed that you seem to be running httpd as a normal user. You can't do that; you need to be logged in as root, or using su or sudo.

    Restore your original httpd.conf file, enter root mode by typing `su` and then start the httpd service.

  10. #9
    Just Joined!
    Join Date
    Aug 2006
    Posts
    1
    there is (at least on my fresh build of fc6 test 2) a bug with the auto httpd setup utility that ships with the OS. it hosed up the httpd.conf file with references to a bunch of non-existent modules. you should have a httpd.conf.bak with the pristine setup in /etc/httpd/conf/. restore that to httpd.conf and you should be golden.

  11. #10
    Linux Newbie Pythagoras's Avatar
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    205

    Question

    I also have problems with httpd. Fails on many lines such as "order access deny". Why mod_access haven't been installed and how to do it manually? Reinstalling by rpm -i --force httpd-[version].rpm dosn't help. What package is mod_access in?
    2b|!2b, that is the question

    If substraction add to multiplication you will get a division.

    GDB has a 'break' feature. Why doesn't it have a 'fix' too?

    Registered Linux User #437662

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •