Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Hi, I downloaded and installed Fedora 5 on my laptop. Partitioned hard drive with winxp on there too. Using the Winxp boot menu, but grub also installed when it reaches ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! monkeysmith's Avatar
    Join Date
    Jul 2006
    Location
    Swansea, UK
    Posts
    14

    Problem after update - Fedora Core 5


    Hi, I downloaded and installed Fedora 5 on my laptop. Partitioned hard drive with winxp on there too. Using the Winxp boot menu, but grub also installed when it reaches the fedora load.

    Got a problem, I ran the update programs in fedora, told me I needed to reboot, and now after I select Fedora from the winxp boot menu, all I get top left of the screen is: GRUB.

    I can't type anything. Any ideas, anyone else had this problem?

    Thanks for any help.

    Richard

  2. #2
    Linux Enthusiast apoorv_khurasia's Avatar
    Join Date
    Feb 2005
    Posts
    624
    I did not know that you can choose Linux from WinXP boot menu. But I would suggest to rewrite your mbr as mentioned in the GNU Grub manual. In particular look for this. In case of any problems please let us know. As a good forum user please post a followup in case this solves your problem (also applicable if you try something different and it works).
    "There is no sixth rule"
    --Rob Pike
    Registered Linux User: 400426 home page

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    the best practice is... you should use only one boot loader ..... in windows what type of boot loader you are using....???
    you can reinstall GRUB... as apoorv wrote in the post...

    boot from fedora installation disk... and type
    $ linux rescue
    $ chroot /mnt/sysimage
    re-install grub...
    $ grub-install

    but i think windows boot loader is going to create problems....
    let c... first reinstall GRUB... and check if both OS, esp. windows booting up smoothly...
    post details of windows boot loader...
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! monkeysmith's Avatar
    Join Date
    Jul 2006
    Location
    Swansea, UK
    Posts
    14
    Thanks for the replies. I think I had kinda messed it all up on my first attempt, I installed the text version too and thought might aswell start again.

    My linux learning curve so far!

    Unable to install in graphical mode, kept getting an error so I just installed as text mode. Reboot and computer it would boot directly into windows as I was a bit nervous of messing up the windows partition, I got the grub settings wrong. Bit of a search on here and google and I created a small (256mb) drive, went into linux rescue mode, mounted the drive and created and copied a boot.lnx file over. Back into windows, moved the boot.lnx file to c:\, edit the windows boot file and enter the file and name fedora. Reboot, woohoo, worked, menu up, pick fedora, and I get a text version! Haha, I thought the text version was the install only, wasnt expecting the whole thing to be in text! Back to the internet, found I need to run startx, that wouldnt work, realised its the crappy shared graphics on the laptop, so edited the xorg.conf file, changed SIS to vesa for the graphics. Startx - that worked. Everytime I rebooted I had to log into text mode then run startx. I ran the upate and my problem above started.

    I thought I'd learnt a little bout linux and thought id start again, so back in with the dvd, fresh install, only this time I install grub with the MBR going on the windows partition. I still couldnt install in graphical mode, but tried 'linux resolution=1024x768' and that worked.

    Reboot, get the grub menu, I removed the windows boot menu, and both boot without problem, and I have the graphical version loading too!

    So far so good, I need to run the program updates, but hopefully should all be ok now I have it setup correctly, i think! Fingers crossed, will keep you posted.

    Thanks

    Richard

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    i must say u researched and googled a lot !!!!
    well !! boot.lnx file... i will try this too.. although i have working dual boot with FC5, SuSe and XP.. but i am going to try boot.lnx too...






    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Linux Newbie
    Join Date
    Aug 2005
    Posts
    213
    You must have meant boot.ini

    Have you tried virtual pc to install fc5 within windows ?
    Its very handy. I tried, installed and then after testing, I did
    a proper installation of fc5.
    Cool Surfer - Registered linux user #397629

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    yeah !! i tried Virtual Pc in windows for FC5 and Ubuntu...... its good !!

    regarding boot.ini or boot.lnx file... i dont know yet.. coz i didnt try... i am curious about this... according to monkeysmith... this file is created by linux not windows... i am going to check this...





    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Just Joined! monkeysmith's Avatar
    Join Date
    Jul 2006
    Location
    Swansea, UK
    Posts
    14
    It's boot.lnx, I got the details from this post:
    http://www.linuxforums.org/forum/ins...questions.html

    I like the look of SuSe, but want to get to know linux first before I pay for it. Might take a look at the opensource version.

  10. #9
    Just Joined! monkeysmith's Avatar
    Join Date
    Jul 2006
    Location
    Swansea, UK
    Posts
    14
    Quote Originally Posted by Cool Surfer
    You must have meant boot.ini
    Ah i see what you mean. the boot.ini file on windows. I created the boot.lnx file in linux rescue mode, moved that onto windows c:\boot.lnx, then edited the windows boot.ini file so it looked like this:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Micro soft Windows XP Professional" /fastdetect /NoExecute=OptIn
    c:\boot.lnx="Fedora Core 5"

    That worked, but after the updates in linux and rebooting, it all went pear shaped, it might not have anything to do with this, but I now use the grub boot menu, and edited the windows boot.ini file to as it was before.

  11. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    in dual boot... only GRUB works fine...
    boot.ini create problems now n then.. it just get corrupted on installing softwares or updates in windows or linux...
    GRUB is best option....





    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •