Find the answer to your Linux question:
Results 1 to 2 of 2
I have a few problems setting up my home network with a router running FC 3. So far i have managed to do the folowing: Router w/ FC3 : ppp0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    4

    Unhappy FC 3 CONNECTIVITY ISSUE / ROUTER w/ADSL on USB


    I have a few problems setting up my home network with a router running FC 3.
    So far i have managed to do the folowing:

    Router w/ FC3 :
    ppp0 - adsl modem on usb
    eth0 - switch - some clients
    eth1 - WinXP box (connected directly to the server)

    Squid is up and running and also ip forwarding has been activated on boot. Fine and dandy so far, its just that all the other clients connected on my eth0 through the switch are all browsing happy through the World Wild Web and I with my XP box, can't.
    I tried to ping the router from the XP box and I get back Destination Port Unreachable.
    What is going on ?
    This is the #ifconfig transcript :

    eth0 Link encap:Ethernet HWaddr 00:80:1E:30:39:95
    inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::280:1eff:fe30:3995/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:427805 errors:0 dropped:0 overruns:0 frame:0
    TX packets:465060 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:48515308 (46.2 MiB) TX bytes:209709395 (199.9 MiB)
    Interrupt:10 Base address:0x2000

    eth1 Link encap:Ethernet HWaddr 00:50:8B:CE:B1:CE
    inet addr:192.168.10.1 Bcast:192.168.10.255 Mask:255.255.255.0
    inet6 addr: fe80::250:8bff:fece:b1ce/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:20134 errors:0 dropped:0 overruns:0 frame:0
    TX packets:856 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1357982 (1.2 MiB) TX bytes:88519 (86.4 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2155 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2155 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2787322 (2.6 MiB) TX bytes:2787322 (2.6 MiB)

    nas0 Link encap:Ethernet HWaddr 00:0E:50:B4:2A:60
    inet6 addr: fe80::20e:50ff:feb4:2a60/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:586036 errors:0 dropped:0 overruns:0 frame:0
    TX packets:487125 errors:6 dropped:0 overruns:6 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:216395456 (206.3 MiB) TX bytes:61027359 (58.2 MiB)

    ppp0 Link encap:Point-to-Point Protocol
    inet addrx.xx.xxx.xxx P-t-P:86.35.77.254 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:573956 errors:0 dropped:0 overruns:0 frame:0
    TX packets:475045 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:210347466 (200.6 MiB) TX bytes:45343341 (43.2 MiB)

    So my clients on this network rely on squid to make them happy, how can I setup named so i can give access through to the WWW without squid ?
    And can someone tell me why can't I ping the router or why cant I access the Web.
    This is part of the transcript that iptables contain :

    *nat
    :PREROUTING ACCEPT [128822:8400558]
    :POSTROUTING ACCEPT [42086:3038546]
    :OUTPUT ACCEPT [36227:2730304]

    -A POSTROUTING -s 192.168.0.0/24 -p tcp -m tcp -o ppp0 -j MASQUERADE
    -A POSTROUTING -s 192.168.10.0/24 -p tcp -m tcp -o ppp0 -j MASQUERADE

    Obviously the settings are correct for both the eth0 users 0.0 and me 10.0... The weirdest thing is that i see Skype connecting and i can make calls i just cant browse the friking web.. Please help.
    Truth is that someone else made the settings for me but left for vacation and i'm stuck, just can;t wait for 2 weeks until he gets back...

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    4
    Does anyone know where I can get an answer ? Like if no one is able to tell me on this forum, can someone direct me to a place i can get some proffesional help ?
    This forum doesnt seem to care too much though

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •