hi friends!



Hi friends!

I tried lot but my system is not detecting modem.
I tried some methods from threads
one is (i am hving a fwp modem and all steps below are for that modem)

Step 1

Connect your telephone to the ttyS1 port. ttyS1 is the same port as COM2 port (we use the term COM2 in Windows). If you use COM1 port then replace all ttyS1 (where you will find in this guide) with ttyS0.
[ COM(x)=ttyS(x-1) ]

Before proceed, you should check that you have fixed the Baud Rate to 115200 in your hand set.

Step 2

If you are able to communicate internet through Windows then there is no problem with it you can proceed to the next step or if there is a need to test your modem, you should produce the following command as root.



[root@localhost user]# wvdialconf /etc/wvdial.conf

Scanning your serial ports for a modem.
---|----


some lines

---|---
Found a modem on /dev/ttyS1.

Modem configuration written to /etc/wvdial.conf.

ttyS1: Speed 115200; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"


If everything is alright you should get similar result. A modem configuration is also be written to \'/etc/wvdial.conf\' with this but as it is not accurate with our need we will slightly change according to our need.

Note : It may happen that you have to provide the command in three/four times to communicate. So don\'t give up unless you have tried the command for three four times. In this time you must be communicated. If not please check your connection.

Now you should edit the file as follows,
Remove three leading `#' symbols from Phone, Username and Password fields.
Put the phone no, in the Phone Field (#777 for reliance) and provide the appropriate username (area code+phone no for reliance) and password (same as username)

Erase the Init2 string value, and put AT+CRM=1 in the init2 field.

Add a line Stupid Mode = 1 at the end of the file.

Save the file /etc/wvdial.conf

Step 3

Do not configure the KPPP unless you understand what you are doing. If you write a configuration file yourself, it is much easier to find the problem in future. I am configuring the file by editing it. If you still want to use KPPP you are encouraged to do it using these parameters. Advanced Connection Settings --> Extra Settings string value and put it as the init2 string value]


Step 4

Now you are almost at the last stage to connect to internet. Give the following command as root.

[root@localhost user]# wvdial



Now what my problemis it does not detect my modem.
error message is Did u configure modem with setserial?
now what is set serial?
I have usb data cable.Is there any driver needed for usb cable?
(Since i get very few time to connect with internet thee days will u allow me to send private message for further quarries?)