Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I am a bit of a Linux novice and I inherited the use of a Linux server a year or so ago. This server has been running just fine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    1

    Grub prompt, possible disk crash


    Hello, I am a bit of a Linux novice and I inherited the use of a Linux server a year or so ago. This server has been running just fine until last week when it was rebooted and the server failed to boot, it stops at a grub command prompt.

    I have searched the forums to get an idea of what I could do. I have tried the following:

    Linux rescue: I found a post which indicated that the MBR may have been corrupted and to use linux rescue and then reinstall grub. My server is running Fedora Core 3 so I inserted the CD, set the BIOS to boot of the CD and issued the linux rescue command. Eventutally I got the error "An error occurred trying to mount some or all of your system. Some of it may be mounted under /mnt/sysimage". From the command prompt I took a look at /mnt/sysimage but it was empty.

    I then tried to boot the server using grub:
    root (hd0,0) returned "filesystem type is ext2fs, partition type 0x83"
    kernel /vmlinuz returned Error 25: Disk read error

    This doesn't sound too good. Anyone any ideas of what I could try. I would like to get the server rebooted if possible. If not I would like to get some files of the disk drive.

  2. #2
    Linux Newbie jagernout's Avatar
    Join Date
    May 2006
    Location
    Indonesia
    Posts
    102
    Hmm..in that case perhaps there are 2 problem.

    1. Error on your kernel conf.
    2. Your HardDrive posibbly having an error sector that cannot read
    -JG-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •