Find the answer to your Linux question:
Results 1 to 9 of 9
Dear All, I want read my Windows file that using NTFS file system, and that must using KMOD-NTFS, but when I was download that file, i can;t install that file, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    9

    Question KMOD-NTFS can't installed in FC5


    Dear All,

    I want read my Windows file that using NTFS file system, and that must using KMOD-NTFS, but when I was download that file, i can;t install that file,
    any one know Version of KMOD-NTFS that support for FC5..
    thank you



    Regards,


    Heru

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by heru_90
    Dear All,

    I want read my Windows file that using NTFS file system, and that must using KMOD-NTFS, but when I was download that file, i can;t install that file,
    any one know Version of KMOD-NTFS that support for FC5..
    thank you



    Regards,


    Heru
    Hello Heru,
    You need the version kmod-ntfs that matches your kernel number
    use uname -r to find kernel version
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    9
    Thank you Mike,
    my kernel version is 2.6.15-1.2054-FC5,
    so where i can find kmod-ntfs version that matches with this kernel version,
    sorry if this disturb you

    thank you for your help


    regards,

    heru

  4. #4
    Just Joined! ToRk's Avatar
    Join Date
    Aug 2006
    Posts
    4

    Smile Hi heru_90

    this may help you choose your kernal ver and go on
    http://www.linux-ntfs.org/content/view/187
    thank you

  5. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    You're welcome,
    And it doesn't disturb me, that's what the forums are for.
    =-}
    The easiest way to install kmod-ntfs is to use yum, but you need to set up the yum repositories first.
    login to a terminal or konsole as root.
    Code:
    su -
    enter root password and press enter.
    then type
    Code:
    kedit /etc/yum.repos.d/livna.repo
    type or paste these lines into kedit.
    Code:
    [livna]
    name=Livna for Fedora Core $releasever - $basearch - Base
    baseurl=
            http://rpm.livna.org/fedora/$releasever/$basearch/
            http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
            http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
            http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
    failovermethod=priority
    mirrorlist=http://rpm.livna.org/mirrorlist-5
    enabled=1
    gpgcheck=1
    Be sure there is a carriage return (blank line) at the bottom of the file. Click the "save" icon in kedit and then close kedit.
    Type this command
    Code:
    rpm --import http://rpm.livna.org/RPM-LIVNA-GPG-KEY
    Then type this command
    Code:
    yum install kmod-ntfs
    You can find this information and much much more on this website.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #6
    Just Joined!
    Join Date
    Aug 2006
    Posts
    9

    Question Thank's Mike and Tork for u'r help

    I was try what your suggestion , and for Kedit there is not work, sorry I'm very new in linux.
    and in your suggestion site I found Kernel-module-ntfs and i was install using default linux installer, but i still can't mount my NTFS file.


    code :
    [root@localhost ~]# kedit /etc/yum.repos.d/livna.repo
    bash: kedit: command not found

    [root@localhost ~]# mount /dev/hda1 /mnt/winc
    mount: unknown filesystem type 'ntfs'

    how the kernel-module work, maybe there is not installed ??

    thank you


    Regards

    heru

  7. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Well I guess your using gnome desktop then?
    Try using gedit instead of kedit, or even use nano
    If you need to learn more about ntfs, including how to set it up and make it work. I suggest you start, here
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi heeru !!

    create a folder in "media" folder
    $ mkdir /media/win_ntfs

    mount the windows ntfs partition
    $ mount -t ntfs /dev/hda1 /media/win_ntfs

    now all your windows files are in win_ntfs...
    you can create a shortcut of this on desktop...

    if logged in as root then log out and log in as normal user
    $ ln -sf /media/win_ntfs /home/<your user name>/Desktop/win_ntfs

    first do this stuff...and check if it works ( i am not sure if you installed kernel module for ntfs correctly) then we look in to editing fstab file

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Aug 2006
    Posts
    9

    Lightbulb Now I can acces my NTFS file

    Dear Mike, Casper, and Tork

    Now I can read my NTFS file,
    I'm wrong for install kernel module version
    thank you for your help


    Regards,


    heru

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •