Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm having problem compiling the new kernel linux-2.6.17.8. Error appears on boot-up: VFS: Cannot open root device "<<NULL>>" or unknow-block (8, Please append a correct "root=" boot option Kernel ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    8

    Kernel Pannic - not syncing VFS : Cannot open root device


    Hi,

    I'm having problem compiling the new kernel linux-2.6.17.8.
    Error appears on boot-up:

    VFS: Cannot open root device "<<NULL>>" or unknow-block (8,
    Please append a correct "root=" boot option
    Kernel Pannic - not syncing VFS : Cannot open root device or unknow-block (8,

    And my grub looks like this:

    /etc/grub.conf

    title Fedora Core 5-new
    root (hd0,0)
    kernel /linux-2.6.17.8

    #lspci
    00:00.0 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
    00:00.1 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
    00:00.2 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
    00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
    00:00.4 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
    00:00.7 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
    00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
    00:0a.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 7
    00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID
    Controller (rev 80)
    00:0f.1 IDE interface: VIA Technologies, Inc.
    VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)


    I understand that the error shows that my IDE controller was not installed in
    the Kernel config. I selected in the make menuconfig:

    DEVICE DRIVERS --> ATA/ATAPI/MFM/RLL --> VIA82CXXX

    But the same error occur while rebooting the kernel. What should be enabled in
    the kernel to fix the problem? Any suggestions?

    I'am building Monolithic Kernel.

    TIA

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    It's odd that the kernel image is in the root partition. Are you sure it's not in /boot? I.e.. /boot/linux-2.8.17.8
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Apr 2006
    Posts
    8
    Quote Originally Posted by Zelmo
    It's odd that the kernel image is in the root partition. Are you sure it's not in /boot? I.e.. /boot/linux-2.8.17.8

    Yes the kernel was in the /boot partition.

    If you change the /etc/grub.conf to your suggestion

    title Fedora Core 5-new
    root (hd0,0)
    kernel /boot/linux-2.6.17.8

    it won't parse even grub.conf file.

    This error showed up after making the following commands:

    #make bzImage
    #cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.17.8
    #cp System.map /boot/System.map-2.6.17.8
    #ln -fs /boot/vmlinuz-2.6.17.8 /boot/vmlinuz
    #ln -fs /boot/System.map-2.6.17.8 /boot/System.map

    #reboot

    Booting the new kernel was working; it showed up at the stage where the boot process look for the system partition. It gets kernel panic afterwards.

    I also tried to modify the grub as follows:

    title Fedora Core 5-new
    root (hd0,0)
    kernel /linux-2.6.17.8 ro root=/dev/sda8

    where /dev/sda8 is the /boot partition of my machine. But it's not helping to escape the kernel panic.

    hope you can help me.

    thanks.

  4. #4
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Well now I'm just more confused about the Grub entries. You say the bzipped kernel image is /boot/vmlinuz (linked to /boot/vmlinuz-2.6.17.8). That sounds exactly right. But Grub is looking for /linux-2.6.17.8. What it should look for is the kernel image, /boot/vmlinuz.

    The other thing that looks like it might be out of whack is the 'root' line, considering that your /boot partition is /dev/sda8. Right now, the root is specified as (hd0,0). Are you sure that's the correct device and partition? That would be the first partition on the first hard disk (according to the Grub manual, Grub doesn't distinguish between IDE, SATA, and SCSI). Grub really needs to know where your root partition is so it can follow the path to your kernel image.
    Stand up and be counted as a Linux user!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •