Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I am trying to install FC5 on my Fujitsu Siemens laptop, and keep the existing Windows XP (dual boot). The laptop has a SCSI 100GB disk drive, with the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    1

    Partitioning error during fedora core 5 setup


    Hi,

    I am trying to install FC5 on my Fujitsu Siemens laptop, and keep the existing Windows XP (dual boot). The laptop has a SCSI 100GB disk drive, with the following layout (in order):

    - One 4,6GB recovery partition from FujitsuSiemens. PRIMARY
    - One 19,5GB System partition containing XP, NTFS, PRIMARY
    - One ~60GB "DATA" partition, NTFS, EXTENDED.
    - 10 GB of free/unused space.

    I made the 10GB free space by deleting the from-the-factory made "DATA" partition, and making a new one 10GB smaller.

    The problem is when I get to the Under the Disk partition Setup:

    - First I tried "Keep all partition and use existing free space", this failed with the message "Could not allocate requested partitions: Partitioning failed: could not allocate Partitions" and some more (not interesting) info when i click OK.

    - Then I tried the custom setup. Here I noticed that I can only create ONE and only ONE partition out of the free space. It does not matter what I try to create. The second always fails no mather if its swap, ext3 or LVM, and the message I get is: "Could not allocate requested partition: Partitioning failed: Could not allocate cylinder based partition".

    Does it fail because there are in fact 3 primary partitions already on my disk, because of the separate "DATA" and recovery partitions? How many primary partitions does Fedora need? I have also tried to boot with the "SystemRescueCD" and use QtParted to pre-format the disks, but even here I can only create one more partition.

    Any ideas on how I can solve this problem? Will it work if i completely delete the "DATA" partition, and then extend the System partition, and then leave around 10GB free for Fedora?

    Any help greatly appreciated!!

    P.S! As you have probably already figured out, I'm a Linux newbie...


    Thomas

  2. #2
    Linux Newbie Pythagoras's Avatar
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    205

    Cool

    When I used RedHat 9 I had 5 partitions on my IDE drive: system, data, boot, root and swap, so I don't think the problem is in the number of partitions. Now my FC5 installation merged swap and root into one volgroup. So try to create a volgroup.
    Another idea is to move data partition to the end of drive to get free 10gb before it. Maybe it will help.
    2b|!2b, that is the question

    If substraction add to multiplication you will get a division.

    GDB has a 'break' feature. Why doesn't it have a 'fix' too?

    Registered Linux User #437662

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi tthomass !!

    Linux or FC5 supports 4 primary partitions and windows .. only 2...
    well !! i think here QTparted is creating problems... sometimes it give strange results like partition overlapping... you should try GParted... its linux based partition manager with GUI... or use harddisk utilities provided by your HardDisk manufacturer... check their WebSite....

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •