Find the answer to your Linux question:
Results 1 to 3 of 3
i think this would get more exposure here, and since i am trying this on fc5, i feel partly justified. i admit that i am not completely stupid when it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Location
    oklahoma
    Posts
    12

    help with vnc on fedora core 5


    i think this would get more exposure here, and since i am trying this on fc5, i feel partly justified.

    i admit that i am not completely stupid when it comes to linux, but i will give it up to the pros and say that i am no genius. i have tried to use vnc on fedora before, and gave up, and i am trying again, and again having trouble, and maybe someone here can point me in the right direction.

    so my setup is as goes: i am running fc5 on an old laptop, and it runs fine (at least until this), and i am trying to connect through my local network with tightvnc on windows xp. my firewall isnt blocking anything, i have checked and rechecked. i can vnc into my mac (running os x) just fine, so the ports are open.

    so i ssh into my fc5 machine, and i type in vncserver, and i get:
    Code:
    New 'localhost.localdomain:3 (jason)' desktop is localhost.localdomain:3
    
    Starting applications specified in /home/jason/.vnc/xstartup
    Log file is /home/jason/.vnc/localhost.localdomain:3.log
    i am guessing this means displays 0 through 2 are already open (from me screwing around with it earlier), and i will have to ask how i shut those down (or whatever i should do).

    from there, i type in Xvnc, and it says

    Code:
    Fatal server error:
    Server is already active for display 0
            If this server is no longer running, remove /tmp/.X0-lock
            and start again.
    so i run tcpdump on the fc5 machine to see what is going on, and then i try to connect to the machine via tightvnc, just to make sure packets are going through, and they are hitting port 5900, just as they should. i try port 5903, and everything is going through the network right.

    what do i do here? what do i check? i am kind of stuck, and i would really like to know how to vnc into this machine.

    thanks for any help. i would appreciate it.

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,890
    Firstly, screen 0 is your regular X login display. If you're using :3 then it'll appear internally as 'localhost:3.0' for X services. If you want to know what VNC servers you keep running, they are configured in /etc/sysconfig/vncservers. If it's not listed in there, then the screen is probably a regular X session.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Location
    oklahoma
    Posts
    12
    the vncservers file says:

    Code:
    # The VNCSERVERS variable is a list of display:user pairs.
    #
    # Uncomment the lines below to start a VNC server on display :2
    # as my 'myusername' (adjust this to your own).  You will also
    # need to set a VNC password; run 'man vncpasswd' to see how
    # to do that.
    #
    # DO NOT RUN THIS SERVICE if your local area network is
    # untrusted!  For a secure way of using VNC, see
    # <URL:http://www.uk.research.att.com/archive/vnc/sshvnc.html>.
    
    # Use "-nolisten tcp" to prevent X connections to your VNC server via TCP.
    
    # Use "-nohttpd" to prevent web-based VNC clients connecting.
    
    # Use "-localhost" to prevent remote VNC clients connecting except when
    # doing so through a secure tunnel.  See the "-via" option in the
    # `man vncviewer' manual page.
    
    # VNCSERVERS="2:myusername"
    # VNCSERVERARGS[2]="-geometry 800x600 -nolisten tcp -nohttpd -localhost"
    so should i uncomment those last 2 lines?

    what does the VNCSERVERS="2:myusername" mean? should i substitute a user for the "myusername"?

    thanks for the reply man. thats awesome.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •