Find the answer to your Linux question:
Results 1 to 3 of 3
Hi pals. Apparently kmid can playback my *.MIDs but no sound is heard! I examined all kmid settings; apparently everything is working, just no sound is heard from spkrs! I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    21

    FC5: Missing midi sound!


    Hi pals.
    Apparently kmid can playback my *.MIDs but no sound is heard!
    I examined all kmid settings; apparently everything is working, just no sound is heard from spkrs!
    I tried kmix settings too, but problem didnt get solved.

  2. #2
    Just Joined! richiefrich's Avatar
    Join Date
    May 2006
    Location
    Houston
    Posts
    88
    As in gentoo I dont know that much of FC5 I had used FC3 but no midi at the time I used it.. here is a post from the gentoo docs

    Note: You will need to copy over SoundFont (SF2) files from your sound card's driver CD or a Windows installation into /usr/share/sounds/sf2/. For example a sound font file for the Creative SBLive! card would be 8MBGMSFX.SF2.

    (First, copy the Soundfont)
    # cp /mnt/win2k/Program\ Files/CreativeSBLive2k/SFBank/8MBGMSFX.SF2 /usr/share/sounds/sf2/
    (Or get it from your SoundBlaster CD)
    # cp /mnt/cdrom/AUDIO/ENGLISH/SFBANK/8MBGMSFX.SF2 /usr/share/sounds/sf2/
    (We load the specific Soundfont)
    # asfxload /usr/share/sounds/sf2/8MBGMSFX.SF2


    thats what we do in gentoo land and it works very very nicely.

    then I installed timidity++ and timidity-eawpatches

    I hope that helps or gives you a starting point.. you can get that file on your windows disk the one that came with your sound card.. Or u can google it either way thats what helped here.

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    21
    I have downloaded and installed these:
    timidity++-2.13.2-1.2.1.i386.rpm
    libmidi++-1.5.0-5mdk.src.rpm
    amidi-plug-0.5.tar.bz2
    libtimidity-0.1.0.tar.bz2
    xmms-timidity-0.1.tar.bz2


    But midi sound is still missing. Also my installed xmms dos not open midi files.
    Im not sure that I have downloaded appropriate pakages and each of theme installed properly. I messed... anyway...
    BTW I found a way to play MIDs with lt-midi2raw; apparently installed by libtimidity-0.1.0. (Indeed i ran 'make check' for it and it played a mid for me!)
    But this way there isnt a graphical interface; it is a command line like: /bin/.libs/lt-midi2raw -r 44100 -s w -c 2 ./ame002.mid |aplay -f cd
    It needs a shell window while playing and for stopping it whenever desired via closing shell window.
    Indeed, I added a context menu option in KDE GUI which runs a shell script containing corresponding command.
    Not too bad?
    Before compromising on this approach I want to see if another relatively easy and better solution (GUI) you can suggest here my pals!; probably regarding xmms plugins & etc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •