Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 23 of 23
Do me favor and type the following command and post the output: chkconfig --list | grep audit...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux User
    Join Date
    Aug 2006
    Location
    Croydon, PA
    Posts
    392

    Do me favor and type the following command and post the output:

    chkconfig --list | grep audit

  2. #22
    Just Joined!
    Join Date
    Jul 2006
    Location
    Kerala,India
    Posts
    31

    Output of chkconfig --list | grep audit

    auditd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
    Can I uninstall and install the demon only? Will that help?
    Can you give me your email? Mine is anoop.anooprs@gmail.com
    I tried yesterday to setup an AOL account, but after I filled in the form, it said some misc error.

  3. #23
    Just Joined!
    Join Date
    Jul 2008
    Posts
    3

    Solution

    I know this thread is old, but I ran into the exact same problem and solved it.

    /etc/init.d/auditd start = fail!

    Same log entries in message about permission denied to /var/log/audit

    But when I ran it directly and bypassed the script /sbin/auditd, it worked just fine. Which got me thinking there was something wrong with the script and not actually with the /var/log/audit permissions.

    The answer is there is a hidden corruption of the rights to /etc/init.d/auditd script. For some reason it has corrupted in such a way that even as root the script doesn't run with root rights.

    To fix it you simply copy /etc/init.d/auditd to another directory. I used /home/user Remove /etc/init.d/auditd. Then copy your backup copy from /home/user back to /etc/init.d/auditd.

    I know it doesn't seem like it should work but it does.

    Problem solved.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •