Find the answer to your Linux question:
Results 1 to 8 of 8
hi Pleeeease help! i've been trying to solve this for days now. I'm new to Linux, Redhat AS 4. I have installed Oracle, and Tomcat 4. I can only open ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    21

    Connection refused when attempting to contact localhost


    hi
    Pleeeease help!
    i've been trying to solve this for days now. I'm new to Linux, Redhat AS 4.
    I have installed Oracle, and Tomcat 4. I can only open "http://localhost:8080" once and then I get the error that says the connection was refused when attempting to contact localhost. I have checked the server.xml but I'm not really sure what to change there. We also use a proxy server here so I don't know if that also contribues to this error. I have also reformatted the machine and installed all RPMs.

    Pleeeease help me out.

  2. #2
    Linux User
    Join Date
    Aug 2006
    Location
    Croydon, PA
    Posts
    392
    Does this server have a name or is it set just at localhost?
    Also post the output of 'cat /etc/hosts'.

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    20
    run system-config-security and then open port 8080; also add 8080 under ports to your /etc/httpd/conf/httpd.conf file and that should make things work; if you need more detail let me know

  4. #4
    Just Joined!
    Join Date
    Sep 2006
    Posts
    21
    Hi Tiberious726
    I found the system-config-securitylevel in /etc/sysconfig. Is this the one you talking about? It has " --disabled", what should I add and remove in that file exactly?

  5. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    20
    oh, sorry yes i did meant securitylevel; and what you should do is open a terminal and type "system-config-securitylevel" to get it to run

    for opening a terminal look under applications>accessories (i have never used red hat's AS just thier fedora core)

  6. #6
    Just Joined!
    Join Date
    Sep 2006
    Posts
    21
    hi
    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    127.0.0.1 demobox.namitech.com demobox
    172.16.167.75 demobox
    172.16.167.75 pegasus

  7. #7
    Just Joined!
    Join Date
    Sep 2006
    Posts
    21
    okay which system-config-securitylevel... there's one in /etc/sysconfig and another in /etc/pam.d. The first one has "--disabled" while the second one has this:

    auth sufficient pam_rootok.so
    auth sufficient pam_timestamp.so
    auth required pam_stack.so service=system-auth
    session required pam_permit.so
    session optional pam_xauth.so
    session optional pam_timestamp.so
    account required pam_permit.so

    And how do I run them for they are not executables?

  8. #8
    Just Joined!
    Join Date
    Sep 2006
    Posts
    20
    type system-config-securitylevel in a terminal; that is how it is exectuted

    (RHAS might not have it... tho i am almost sure that it does)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •