Find the answer to your Linux question:
Results 1 to 3 of 3
hi all i m having fedora core 4 booting problem Filesystem type is ext2fs wen i boot the machine after uncompressing linux it shows No volume groups found unable to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    22

    No volume groups found "VolGroup00"


    hi all
    i m having fedora core 4 booting problem
    Filesystem type is ext2fs
    wen i boot the machine
    after uncompressing linux it shows No volume groups found
    unable to find volume group "VolGroup00"
    ERROR: /bin/lvm exited abnormally with value 5 ! (pid 457)
    mount: error 6 mounting ext3
    ERROR opening /dev/console!!!!: 2
    error dup2íng fd of 0 to 0
    error dup2íng fd of 0 to 1
    error dup2íng fd of 0 to 1
    switchroot: mount failed: 22
    kernel panic - not syncing : Attempted to kill init!
    b4 this i had some other bootable problem
    in that problem the error was
    can't find /dev/pts in /etc/fstab or /etc/mtab wen i was getting this problem
    i used one utility to repair the machine but i think i screwed it up completely
    wat i did is i ran some command
    1).To create ext3 on hda2
    #mke2fs -j /dev/hda2
    2). To convert ext2 to ext3
    #tune2fs -j /dev/hda2
    3).To repair i ran
    #e2fsck -p /dev/hda2
    i dont know wat happened
    is it i deleted all the data on hd by converting ext2 to ext3
    i dont know wat to do
    plz help me
    thnx
    regards

  2. #2
    Linux User glussier's Avatar
    Join Date
    Sep 2006
    Location
    Montreal, Qué, Canada
    Posts
    255
    When you isntalled fedora, you probably have let the installer decide of the partitionning. The installer chose to use LVM (logical groups and volumes). Then you started playing with the partitions as if they were physical partitions and you screwed-up everything.

    I think you should plan a reinstall and when asked if you want to use the default Fedora partitions, select to partition the drive yourself.

    If you do decide to use LVM, I suggest you read a bit about LVM and the tools used to maintain that type of structure.

    If you have data that you want to recover, you might want to try a live cd to do so, but I'm not sure if there are any livecds which include a kernel with lvm support.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi !!

    you created new partition and changed format type. there isn't any entry for this new partition in fstab file. boot up through FC4 installation CD and check the output of fdisk -l and make neccessary changes in fstab file.



    .... casper ....
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •