Find the answer to your Linux question:
Results 1 to 3 of 3
I have been using linux recreationally for some time now, since the days of Red Hat 9. I saw the conception of Fedora Core and the subsequent versions (only of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2

    Horrible Install Problem FC6


    I have been using linux recreationally for some time now, since the days of Red Hat 9. I saw the conception of Fedora Core and the subsequent versions (only of which I have used 1,4 and now trying 6). For the life of me, I can not get this or any install of FC6 to work. I just built my computer not to long ago (2 months maybe)(being the tech guy I am). My roomate built his about 6 months ago. Neither of us can get it running but another guy in my dorm (yes, I am a college student, senior, finally) can get it running without a hitch on his older system.

    I have:
    2.8GHz Celeron processor
    Gigabyte GA-945p-S3 motherboard
    1gb ram
    Samsung 250gb Sata hdd
    80gb WD hdd attached to a Syba Ultra ATA IDE contoller card
    40gb WD external portable usb hdd

    This should be the important stuff.
    I am trying to install onto xfs if possible. I first tried to install FC6 (hencefore may be refered to simply as linux) on the 250 first. I have a 180gb windows install that i'd rather not move and a 20gb Mac OS X 10.4.4 install that I don't want to touch (it works, so I won't "fix" it). This leaves me roughly 50gb to play with, but well after the 1024 cylinder and still very far down the partition line. This gave no results, the first error I had was "Grub geom error". Used my windows XP Pro disc to "fixmbr" and got my old bootloader back. Figured i'd install it on the usb drive, so I used "linux xfs expert". Got it on the usb drive. Still, installed grub. No error, just a hang on "Grub_" and nothing. Tryed to reinstall, to no avail. Figured I'd install to the 80gb ide drive. I've tried that twice now.
    With the most recent install, I have installed grub, not on the mbr, but on the first partition of hda. At first grub wouldn't work, but i used "root" command from the grub prompt and kept trying partitions until I got (hd0,1) to recognize as ext2 (which is what my /boot area is, / being xfs). Seeing as this is the only ext2 partition in the entire computer, this should be the right one. I then used "setup (hd0)" to install grub. It seems to go ok, saying it didn't find stage1 from /boot but did find stage1 in /grub/boot (i think this path is correct) and then went on like it seemingly is suppose to. Now when I use my motherboards boot device choose, I choose the 80gb drive, and grub starts up, but the grub.conf file is wrong and points to (hd2,1) and says filesystem is incorrect. A simple change of this to 0,1 and the kernel and vmlinuz are loaded but then my problem occurs. At "Red Hat nash version 5.1.19 starting", it hangs and proceeds no further.
    This post is long to explain, hopefully, my entire setup and thus more clue in to how to troubleshoot it. Is xfs causing the problem? Is my BIOS (which I have updated to the most recent version from gigabyte) the problem? Am I missing some critical fix that is so simple, but I haven't known about? Any help would be great. I've spent countless hours on this and don't mind putting in a few more to get it to work. Fedora Core is fastly approaching my "Worst OS install ever", it has already taken "Longest/Tediest Linux install ever". Thanks.

    Edit: I am trying to install the 64bit version, and yes, the celeron is 64bit capable.

  2. #2
    Just Joined! anthq's Avatar
    Join Date
    Jun 2006
    Posts
    62
    first of all, if you built your computer 2 months ago, very nice choice (and i hate celerons) going with the celeron 2.8 - very cheap $$, you could pick up core 2 once they go down.

    to get the windows bootloader back, in the xp recovery console, you should do fixboot and fixmbr.

    also, when i do my install, i always do a custom partition layout do a large amount (in your case maybe 48 GB) for mount point '/', and about 1GB for swap. be warned though - my computer had crashed before i installed fc6, and so i reinstalled xp and fc6, and xp, after doing the partition this way, gave a bsod "unmountable boot volume". next i reinstalled xp and installed sp2, and set up fc6, leaving a bit of free unpartitioned space on the drive. this way worked.

    also, in the fc6 install, check out what name each partition is (sda1, sda2, hda1, hda2, etc), and make sure that later in the install the grub config matches the correct hd partitions.

    also, let me know where you got that osx! i borrowed a dvd from a friend (OSX 10.4.7) and it installed wonderfully, but when booting up it just showed the loading thing with the apple logo, and after a while, it shows a circle with a lne through it (like the no smoking sign, lol). the installer was called something like JasOS or something.

    dont know if this helped, but let me know what happens!

    good luck!

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2
    I am in class right now, so I haven't had the chance to retry FC6 again. Last nigth I did try to install Ubuntu 4.10 and Gentoo 2006.1, still, to no avail. Ubuntu errored in the install. Gentoo installed, but errored in something and now I can't start windows again. I installed Vista RC1 and that gave me a bootable OS but now.... my regular XP Pro can not boot. I edited the BCD store and it added the XP as a possible windows installation and added the entry but when I go to boot I get an error trying to boot XP says missing "\ntldr", looks like another round of fixboot and fixmbr. So much frustration. This is looking grim... and I looked up on Gigabytes site, they say the strive to make linux friendly boards... hahaa.... what is messing up then.

    In response to anthq I hate celerons also, but I didn't have quite enough money to finish out with a core 2 (but the mobo supports it, I bought it that way to upgrade asap). I do know about fixboot and fixmbr, have been using them extensively throughout this process. I did a custom partition, and even tryed to do default partitions, none work. Thanks though, I am going to try to double check the grub configuration a little more closely this time around. It only takes about 30 minutes to install so it's not terrible.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •