Find the answer to your Linux question:
Results 1 to 7 of 7
I am trying to instal a NTFS driver for Fedora core 6. Here are the instructions: How to install ntfs-3g for Fedora Core 6? * Install the ntfs-3g package from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    TUK
    TUK is offline
    Just Joined!
    Join Date
    Dec 2006
    Posts
    28

    NTFS driver install problem >>> bash: usermod: command not found


    I am trying to instal a NTFS driver for Fedora core 6.
    Here are the instructions:

    How to install ntfs-3g for Fedora Core 6?

    * Install the ntfs-3g package from Fedora Extras:

    $ yum install ntfs-3g

    * In the /etc/udev/rules.d/50-udev.rules replace this line:

    SUBSYSTEM=="block", GROUP="disk", MODE="0640"

    with the following line:

    SUBSYSTEM=="block", GROUP="disk", MODE="0660"

    * Add the user to the disk and fuse group:

    $ usermod -a -G disk,fuse username

    * Change permissions of the directory where you want to mount the NTFS partition to 777:

    $ chmod 777 /media/hda1

    * Add this line to /etc/fstab:

    /dev/hda1 /media/hda1 ntfs-3g dmask=022,fmask=133,noauto,locale=hu_HU.UTF-8,user 0 0

    * If you want to allow other users to access the mounted NTFS partitions, not only the user who mounted it, run this command:

    $ echo user_allow_other >> /etc/fuse.conf

    * If you want to automatic mount your NTFS partition in GNOME, run this command:

    $ rm -f /usr/share/hal/fdi/policy/10osvendor/99-redhat-storage-policy-fixed-drives.fdi
    Everything seems to go ok, until I try this part

    [root@k1 tuk]# usermod -a -G disk,fuse tuk
    bash: usermod: command not found
    [root@k1 tuk]#

    I should mention Iv only been using Linux for a few days now

    Thanks

  2. #2
    TUK
    TUK is offline
    Just Joined!
    Join Date
    Dec 2006
    Posts
    28
    I have to say feedback on this forum is quite slow, I have been searching on google and within forums for solutions tro my problems, but finding it difficult..

    It seems that I need to ...'Install the shadow-utils package' to get usermod working

    Does anyone know how to do this?

    I would really like to get this method working, I tried caspers method for installing NTFS driver:
    http://www.linuxforums.org/forum/red...ugs-fixes.html

    This works, but means having to lower Firewall security, which is against all my best instincts, Im already worried about FC6 security as it is.
    Last edited by devils casper; 03-05-2007 at 08:40 AM.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    i have already mentioned in this tutorial that i have standalone Home PC and i disabled FireWall and SeLinux. i dont know if its possible to enable write access using ntfs-3g without setting SeLinux to permissive mode or disabling it.





    Casper
    Last edited by devils casper; 03-05-2007 at 08:43 AM.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2
    Try using --groups instead of -G. It works for me!






    Quote Originally Posted by TUK
    I am trying to instal a NTFS driver for Fedora core 6.
    Here are the instructions:




    Everything seems to go ok, until I try this part

    [root@k1 tuk]# usermod -a -G disk,fuse tuk
    bash: usermod: command not found
    [root@k1 tuk]#

    I should mention Iv only been using Linux for a few days now

    Thanks

  5. #5
    Linux Newbie
    Join Date
    Feb 2007
    Location
    San Antonio, TX
    Posts
    114
    The problem is that his distro doesn't have the command "usermod", so doing "usermod --groups" would have the same problem as "usermod -G", since he doesn't have usermod


    Anyway, it's a simple problem, no need to install anything. All you have to do is add your user to the disk and fuse groups, usermod is just a tool that lets you do that from the command line. Alternatively you could run
    Code:
    system-config-users
    click the "groups" tab, add the groups "disk" and "fuse" if they're not there already, double click on them, click the "group users" tab, and put a check box next to every user you want to add to those groups.

  6. #6
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2
    Im using the same distro FC6 (64-bit) and YES, it has the usermod command, Ive had exactly the same problem. using --groups instead of -G
    and it really solves the problem.



    "Between the believings of a man and the reality, usually is an abyss of a thousand light years, an abyss that only some men can cross"








    Quote Originally Posted by TUK
    I am trying to instal a NTFS driver for Fedora core 6.
    Here are the instructions:



    Everything seems to go ok, until I try this part

    [root@k1 tuk]# usermod -a -G disk,fuse tuk
    bash: usermod: command not found
    [root@k1 tuk]#

    I should mention Iv only been using Linux for a few days now

    Thanks

  7. #7
    Linux Newbie
    Join Date
    Feb 2007
    Location
    San Antonio, TX
    Posts
    114
    perhaps when he switched to root he did
    Code:
    su
    instead of
    Code:
    su -
    if he has usermod it should be located in /usr/sbin/, the contents of which are only in root's path. Just typing "su" would give root permissions but wouldn't reset the path to root's, so it wouldn't look in /usr/sbin/ for commands, and would result in "command not found". "su -" would reset the path to root's and would find that file in /usr/sbin/, if it exists.

    my point, though, was that changing the arguments to "usermod" wouldn't make any difference if the computer can't find the command "usermod" to begin with, which is what his error is describing. Besides, the result of that command can be accomplished through other means anyway, it's no big deal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •