Find the answer to your Linux question:
Results 1 to 2 of 2
I have been trying to get a standard, updatable and bootable CentOS 4.4 install onto my 4G Lexar Firefly USB pendrive. I am at a loss as to why I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1

    Bootable Install Onto Pendrive - kernel panic!


    I have been trying to get a standard, updatable and bootable CentOS 4.4 install onto my 4G Lexar Firefly USB pendrive.

    I am at a loss as to why I get the following errors in the startup:

    ***************************************

    Booting 'CentOS-4 i386 (2.6.9-42.EL)'

    root (hd0,0)
    Filesystem type is ext2fs, partition type 0x83
    kernel /vmlinuz-2.6.9-42.EL ro root=LABEL=/ rhgb quiet
    [Linux-bzImage, setup=0x1400, size=0x16dd65]
    initrd /initrd-2.6.9-42.EL.img
    [Linux-initrd @ 0x1fefe000, 0x612ef bytes]

    Uncompressing Linux... Ok, booting the kernel.
    Red Hat nash version 4.2.1.8 starting
    mkrootdev: label / not found
    mount: error 2 mounting ext3
    mount: error 2 mounting none
    switchroot: mount failed: 22
    umount /initrd/dev failed: 2
    Kernel panic - not syncing: Attempted to kill init!

    ***************************************

    This is what I did:

    - installed CentOS 4.4 from CDs using "expert mode"
    - grub bootloader
    - /dev/sda1 mounted on /boot 100M
    - /dev/sda2 mounted on / 3.9G
    - no swap
    - server install (w/gdm)

    It was suggested that I may be having an issue with USB drivers not getting
    installed, so I ran mkinitrd including them. I also uncompressed initrd.gz and
    tried to add them manually - I had no luck with either method.

    Also, someone told me that /dev/sda2 was not labelled - I ran e2label and the label is "/".

    Since I am by no means a Linux expert (my background is in data and voice
    networking), any and all suggestions and URLs will be appreciated!

    Mark

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    22
    1/ I suspect that you didn't install grub correctly.
    Check the file /boot/grub/device.map and see what
    hd0 is. I'd wager it's NOT /dev/sda. You need to
    run grub-install with the --root-directory=(... the sda1 boot dir)
    and the install device as /dev/sda . Also fix the
    /boot/grub/menu.conf to point at the correct hd# for
    the sda device.

    2/ You need to have the scsi driver (sda) loadable module
    included on the initrd... . To do this you can add the correct
    line to the /etc/modprobe.conf file before the mkinitrd is
    executed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •