I have an SATA drive that I'm using as a backup drive. It is in a removable slot, and I swap them once a week.

The drives are not found in fstab. I mount and unmount them manually.

Typically, after I mount them I am able to write to the drive using my backup scripts. I run a full backup of my data drive once a week, and 3 incremental backups daily.

What seems to be happening is during the night, when the backups are supposed to run, the drive kicks into a mode that indicates it is "rw" but won't let me write to the drive!

Here are some examples of this issue.

Here is what a "mount -l" shows:

[root@tatiana ~]# mount -l
/dev/hda1 on / type ext3 (rw) [/]
/dev/proc on /proc type proc (rw)
/dev/sys on /sys type sysfs (rw)
/dev/devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/shm on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid2004) on /misc type autofs (rw,fd=4,pgrp=2004,minproto=2,maxproto=4)
automount(pid204 on /net type autofs (rw,fd=4,pgrp=2048,minproto=2,maxproto=4)
/dev/sdb on /data type ext3 (rw) [raid2]
/dev/sda1 on /bkup type ext3 (rw) [bkup1]

The drive at issue is /dev/sda1 which is mounted to /bkup.

When I try to run a tar command, it tells me the drive is read only!

[root@tatiana ~]# find /data/* -mmin -240 -type f -print | tar cvf /bkup/incr/$(date +%a)/$(date +%a-%H).tar -T - 2>>//bkup/incr/$(date +%a)/errors_$(date +%a-%H).log >>/bkup/incr/$(date +%a)/files_$(date +%a-%H).log
-bash: //bkup/incr/Tue/errors_Tue-10.log: Read-only file system

I have found that when I can get the drive unmounted (sometimes it's busy and I can't unmount it at all!), I can remount it and run the commands fine.

However, usually when I come in the next morning, my scripts didn't run overnight because it becomes a "Read-only file system".

But as you can see from the "mount -l" it is rw.

Also, I tried to remount it as rw, and here is what it tells me:

[root@tatiana ~]# mount -o remount,rw /dev/sda1
mount: block device /dev/sda1 is write-protected, mounting read-only
[root@tatiana ~]#


Any help is appreciated.

Thanks.