Find the answer to your Linux question:
Results 1 to 4 of 4
I made a shared partition between windows and linux on my computer. I have full access to the partition in windows. In linux I have only partial access. The linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    18

    writing to a shared partition in linux


    I made a shared partition between windows and linux on my computer.
    I have full access to the partition in windows.
    In linux I have only partial access.
    The linux permissions look like this.

    Owner has: read, write, and execute.
    Group has: read, and execute.
    Other has: read, and execute.
    the location of the partition is /storage and is a vfat partition.
    I have tried using the chmod commands in superuser mode but I am just not able to change the permissions.

    The folders location is /storage and is a vfat or fat32 partition.

    I need to have full access in linux and windows
    does anyone have a soultion?

  2. #2
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    what does your /etc/fstab file look like? could you post it, please?

    if it is not there already, what you might try doing is adding the following mount options to your /etc/fstab entry: users,umask=0000

    so for example, you might see something like this:
    Code:
    /dev/hda1  /storage  vfat  noauto  0 0
    You would change that to:
    Code:
    /dev/hda1  /storage  vfat  noauto,users,umask=0000  0 0
    these options mean: allow all users to mount the device, and set the permissions to read/write/execute for everyone

    hope that helps.
    Avatar from xkcd.com, a hilarious computer related webcomic.

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    18
    LABEL=/ / ext3 defaults 1 1
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    /dev/sda7 /storage vfat defaults 0 0
    sysfs /sys sysfs defaults 0 0
    LABEL=SWAP-sda7 swap swap defaults 0 0

    I change it to this:

    LABEL=/ / ext3 defaults 1 1
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    /dev/sda7 /storage vfat noauto,users,umask=0000 0 0
    sysfs /sys sysfs defaults 0 0
    LABEL=SWAP-sda7 swap swap defaults 0 0

    still no go ill try rebooting and running chmod again.
    Ok well now all the files are missing in that folder now....so that did not work.

    [EDIT]

    woot, I got it thanks for the help. the code I used was:

    LABEL=/ / ext3 defaults 1 1
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    /dev/sda7 /storage vfat users,umask=00000 0
    sysfs /sys sysfs defaults 0 0
    LABEL=SWAP-sda7 swap swap defaults 0 0

  4. #4
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    excellent.

    sorry, i forgot that you might want that partition to mount automatically

    glad it works now.
    Avatar from xkcd.com, a hilarious computer related webcomic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •