Find the answer to your Linux question:
Results 1 to 3 of 3
I had to load FC6 on an IDE because the install could not find my two SATA drives, bummer. This is a dual boot system with windows XP media center ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Location
    Rural Kentucky
    Posts
    7

    Unhappy FC6 does not recognize SATA more info


    I had to load FC6 on an IDE because the install could not find my two SATA drives, bummer. This is a dual boot system with windows XP media center as the installed OS. After getting FC6 running I opened a terminal window and found these entries in dmesg.

    ata3 sata max UDMA/133 cmd 0x9E0 ctl 0xBE2 bmdma 0xcc00 irq 153
    sata_nv 0000:00:0e.0: irq 153 request failed -38

    similar error report on the other sata drive. These both work fine in windows.

    I am running linux version 2.6.18-1.2798.fc6
    The system is a compaq presario SR2020NX 512MB
    The second drive is setup with free space as I intended for the linux install to go there.

    I had to use acpi=off to get the fc6 DVD to run. looking at www.linux-ata.org it would seem that sata_nv would be the correct driver?

    I have spent a lot of time looking through the linux forum web site and the fedora web site. I see a lot of SATA problems reported. I do not see any clear solutions.

    any ideas on commands I might run to see what is not working?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Some SATA chipsets have been supported since practically forever, as their programming interfaces are unchanged from PATA predecessors. Others are brand-new and require new drivers from scratch.
    check here for workarounds.





    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Location
    Rural Kentucky
    Posts
    7

    FC6 cannot see SATA drive on my chipset

    Update; I never found any solution on any forums and none of the suggestions led anywhere expcept to go to Bugzilla and see if there were any bugs on this topic. Yes there was ONE? after all the troubles on Sata I have seen I was surprised not to find duplicate BUG reports.
    So to help with making the bug more encompassing I added comments to BUG 181003 to describe my particular mobo and chipset and the errors in the dmesg which showed my two SATA hard drives failing to respond to irqs.
    My machine does load the sata_nv module but it still doesn't work with that chipset. Bug 181003 is marked as a high priority so maybe those of us having to load on IDE drives will get to use our Sata drives soon.

    thanks to all who made suggestions or to all who detailed their experiences with sata drives on their various machines.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •