Find the answer to your Linux question:
Results 1 to 2 of 2
Good morning. I don't have to much experience setting OpenLDAP. I am able to run the ./slapd -f /slapd.conf -u root with no errors and I can confirm that is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    OpenLdap - slap_startup failed


    Good morning.

    I don't have to much experience setting OpenLDAP.

    I am able to run the ./slapd -f /slapd.conf -u root with no errors and I can confirm that is running when I type ps -ef | grep slapd.

    My problem is when I try to add data to the first time to the directory:

    slapadd -v -l /tmp/ldif/ldaprootnode.ldif

    I get this error:

    bdb_db_open: database already in use
    backend_startup_one: bi_db_open failed! (-1)
    slap_startup failed

    Can some body give me some ideas..

    Regards,

    Epina

  2. #2
    Just Joined!
    Join Date
    Jan 2008
    Posts
    1

    Smile

    Hi, I just saw your post and I have or had the same problem, I had to stop the server first

    ./slapd stop

    before I added the new LDIF file. I'm still have problems though with my DIT so it still didn't update the database because my config is probably wrong (That's my next problem to solve). Anyway just though I should mention it to you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •