Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
When i do "updatedb" updatedb: can not open a temporary file for `/var/lib/mlocate/mlocate.db' Any ideas? 4th...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Dec 2006
    Location
    Manchester, UK
    Posts
    25

    When i do "updatedb"

    updatedb: can not open a temporary file for `/var/lib/mlocate/mlocate.db'

    Any ideas?




    4th

  2. #12
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    you removed 'Python' and Yum depends on Python. find Python 'rpm' files in RPMS folder in Installation CD/DVD. copy to harddisk and execute
    Code:
    rpm -ivh <python-package>




    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #13
    Just Joined!
    Join Date
    Dec 2006
    Location
    Manchester, UK
    Posts
    25
    I think I've pretty much sorted it - thanks to skiboy and casper

    When I tried to install python RPM file from the DVD, it said:

    error: Failed dependencies:
    python = 2.4.4-1.fc6 is needed by python-devel-2.4.4-1.fc6.x86_64
    python < 2.4.4-1.fc6 conflicts with python-devel-2.4.4-1.fc6.x86_64


    So i did rpm -e on "python-devel-2.4.4-1.fc6.x86_64", leaving me with "python-devel-2.4.3-18.fc6.x86_64". RPM then installed "python-2.4.3-18.fc6.fc6.x86_64.rpm" fine. Yum was all good after that, and I'm now downloading my updates through the command line.

    Thanks again you guys. This is probably a really noobish thing to say but I'm growing to like using the terminal!




    4th

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Dec 2006
    Location
    Manchester, UK
    Posts
    25
    Ok that was a little presumptive. It still won't update correctly. It installs ther openoffice.org updates. But then I get a similar error as before. Er...it's a bit long...

    Transaction Check Error: file /sbin/mkinitrd from install of mkinitrd-5.1.19.0.2-1 conflicts with file from package mkinitrd-5.1.19-1
    file /etc/gconf/schemas/totem.schemas from install of totem-2.16.3-1.fc6 conflicts with file from package totem-2.16.1-1.fc6
    file /usr/share/applications/totem.desktop from install of totem-2.16.3-1.fc6 conflicts with file from package totem-2.16.1-1.fc6
    file /usr/share/totem/totem.glade from install of totem-2.16.3-1.fc6 conflicts with file from package totem-2.16.1-1.fc6
    file /usr/share/gtk-doc/html/pango/PangoEngineLang.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/PangoEngineShape.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/PangoFcDecoder.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/PangoFcFont.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/PangoFcFontMap.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/PangoMarkupFormat.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/index.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/index.sgml from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix01.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix02.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix03.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix04.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix05.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix06.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix07.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix08.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/ix09.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/lowlevel.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-ATSUI-Fonts.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Cairo-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Coverage-Maps.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Engines.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Fonts.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-FreeType-Fonts-and-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Glyph-Storage.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Layout-Objects.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Miscellaneous-Utilities.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Modules.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-OpenType-Font-Handling.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Scripts.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Tab-Stops.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Text-Attributes.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Text-Processing.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Win32-Fonts-and-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-X-Fonts-and-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-Xft-Fonts-and-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango-querymodules.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango.devhelp from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/pango/pango.devhelp2 from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
    file /usr/share/gtk-doc/html/hal/ch01.html from install of hal-devel-0.5.8.1-6.fc6 conflicts with file from package hal-devel-0.5.8.1-6.fc6
    file /usr/share/gtk-doc/html/hal/ch02.html from install of hal-devel-0.5.8.1-6.fc6 conflicts with file from package hal-devel-0.5.8.1-6.fc6
    file /usr/share/gtk-doc/html/hal/hal-libhal-storage.html from install of hal-devel-0.5.8.1-6.fc6 conflicts with file from package hal-devel-0.5.8.1-6.fc6
    file /usr/share/gtk-doc/html/hal/hal-libhal.html from install of hal-devel-0.5.8.1-6.fc6 conflicts with file from package hal-devel-0.5.8.1-6.fc6
    file /etc/gaim/prefs.xml from install of gaim-2.0.0-0.26.beta5.fc6 conflicts with file from package gaim-2.0.0-0.15.beta3.fc6
    file /usr/share/applications/gaim.desktop from install of gaim-2.0.0-0.26.beta5.fc6 conflicts with file from package gaim-2.0.0-0.15.beta3.fc6
    file /usr/share/man/man1/gaim.1.gz from install of gaim-2.0.0-0.26.beta5.fc6 conflicts with file from package gaim-2.0.0-0.15.beta3.fc6
    file /usr/share/man/man3/Gaim.3pm.gz from install of gaim-2.0.0-0.26.beta5.fc6 conflicts with file from package gaim-2.0.0-0.15.beta3.fc6
    file /usr/share/pixmaps/gaim/smileys/default/theme from install of gaim-2.0.0-0.26.beta5.fc6 conflicts with file from package gaim-2.0.0-0.15.beta3.fc6
    file /usr/share/man/man1/ftrace.1.gz from install of frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package frysk-0.0.1.2006.10.02.rh1-1.fc6
    file /usr/share/man/man8/funit-child.8.gz from install of frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package frysk-0.0.1.2006.10.02.rh1-1.fc6
    file /usr/share/man/man8/funit-exec.8.gz from install of frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package frysk-0.0.1.2006.10.02.rh1-1.fc6
    file /usr/share/man/man8/funit-threads.8.gz from install of frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package frysk-0.0.1.2006.10.02.rh1-1.fc6
    file /usr/share/man/man8/funit.8.gz from install of frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package frysk-0.0.1.2006.10.02.rh1-1.fc6

    Do I have to manually remove all the old versions using rpm -e or something?



    4th

  6. #15
    Just Joined!
    Join Date
    Dec 2006
    Location
    Manchester, UK
    Posts
    25
    Anyone...? I see Ankhar has a similar problem here - and with a lot of the same packges...






    4th

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •