Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all, Appologies if this is an incredibly situpid question, but I've only been using linux for 3 days now, and I'm a bit stuck. I'm just trying to get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2

    RPM issue - Real newbie here!


    Hi all,

    Appologies if this is an incredibly situpid question, but I've only been using linux for 3 days now, and I'm a bit stuck.

    I'm just trying to get my modem working with an RPM I downloaded - I installed it and I now want to uninstall it, but this is what I get:

    [root@dbdbglon42899 dan]# rpm -vhi ltmodem*
    Preparing... ########################################### [100%]
    package ltmodem-kv_2.4.22_1.2115.nptl-8.26a9-1 is already installed
    [root@dbdbglon42899 dan]# rpm -e ltmodem*
    error: package ltmodem-kv_2.4.22_1.2115.nptl-8.26a9-1.i686.rpm is not installed
    [root@dbdbglon42899 dan]#

    So it won't uninstall it.

    Thanks in advance for any replies!

    Dan

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    try getting the exact name of the modem package (which will NOT have the .rpm at the end) by :-
    Code:
    rpm -qa | grep 'ltmode'
    then use that exact name in your erase
    Code:
    rpm -e exact-name-of-package
    obviously change the "exact-name-of-package" with whatever the previous query command has thrown up.



    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2

    you sank my battleship!

    wow - what speed!

    And yet another thing I have learned today!! I love this!

    thanks for that, much appreciated. As you can tell, I am trying to get my modem (winmodem!) working, and I wanted to uninstall that package before trying anything else..



    [root@dbdbglon42899 dan]# rpm -qa | grep 'ltmode'
    ltmodem-kv_2.4.22_1.2115.nptl-8.26a9-1
    [root@dbdbglon42899 dan]# rpm -e ltmodem-kv_2.4.22_1.2115.nptl-8.26a9-1
    Deleted device node /dev/ttyLT0
    lrwxrwxrwx 1 root root 11 Apr 29 10:35 /dev/modem -> /dev/ttyLT0

    Finished device node cleanup.
    Removing the following Lucent DSP modem support lines from /etc/modules.conf:
    -----------------
    # lt_drivers: autoloading and insertion parameter usage
    alias char-major-62 lt_serial
    alias /dev/tts/LT0 lt_serial
    alias /dev/modem lt_serial
    # The next two lines are syntax examples, only Rarely Needed, to automate parameter usage during lt_drivers insertion. See documentation for details.
    # options lt_modem vendor_id=0x115d device_id=0x0420
    # options lt_modem Forced=3,0x130,0x2f8,0
    # section for lt_drivers ends
    -----------------
    Support lines removed:
    ----------------------------
    --------------------------

    Updating the modules configuration files with:
    depmod -a
    Checking dependencies of remaining modules.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    was the piece in the tutorial section of any help to you?



    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  6. #5
    Just Joined!
    Join Date
    Apr 2004
    Location
    London Uk
    Posts
    12
    Can't offer you help mate, well kind of..... As I was reading your post the word LUCENT popped out and raised it's ugly head... I am probably going to get a few funny comments back about this but stay away from anything with the words LUCENT written on it. Avoid it like the plague, in fact run in to the hills and dig a big hole and hide in it, you will be far better off.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •