Find the answer to your Linux question:
Results 1 to 6 of 6
I am running RH EL4 I have to install glibc-devel-2.3.2-5.20.i386.rpm to get /usr/lib/crt1.o crti.o and crtn.o 1. I downloaded the rpm and ran rpm -i I get the following message: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4

    glibc-devel rpm help


    I am running RH EL4

    I have to install glibc-devel-2.3.2-5.20.i386.rpm to get /usr/lib/crt1.o crti.o and crtn.o

    1. I downloaded the rpm and ran rpm -i

    I get the following message:

    error: Failed dependencies:
    glibc = 2.3.2 is needed by glibc-devel-2.3.2-95.20.i386
    glibc-headers = 2.3.2 is needed by glibc-devel-2.3.2-95.20.i386

    2. To try to fix the dependencies, I downloaded

    glibc-2.3.2-95.20.i686.rpm glibc-headers-2.3.2-95.20.x86_64.rpm

    3. Then running
    # rpm -i glibc-2.3.2-95.20.i686.rpm

    give me this error

    error: Failed dependencies:
    glibc-common = 2.3.2-95.20 is needed by glibc-2.3.2-95.20.i686
    glibc < 2.3.4 conflicts with glibc-common-2.3.4-2.x86_64

    4. Any ideas on how to fix this or what is the correct procedure?

    Thanks
    Zim

  2. #2
    Linux Enthusiast likwid's Avatar
    Join Date
    Dec 2006
    Location
    MA
    Posts
    649
    The file can reside anywhere, but keeping an archive of installed rpm's is good. You need to satisfy the dependencies before installing the devel package though, just download the versions it says it needs.

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4
    Quote Originally Posted by likwid
    The file can reside anywhere, but keeping an archive of installed rpm's is good. You need to satisfy the dependencies before installing the devel package though, just download the versions it says it needs.
    I downloaded these two rpms
    glibc-2.3.2-95.20.i686.rpm glibc-headers-2.3.2-95.20.x86_64.rpm

    and now get a different error of a conflict

    # rpm -i glibc-2.3.2-95.20.i686.rpm
    error: Failed dependencies:
    glibc-common = 2.3.2-95.20 is needed by glibc-2.3.2-95.20.i686
    glibc < 2.3.4 conflicts with glibc-common-2.3.4-2.x86_64

    Where these the correct rpms to download? which one should be run first glibc-headers or glibc?
    I'll get glibc-common and try again

  4. $spacer_open
    $spacer_close
  5. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Did you notice that you are mixing 64 bit and 32 glibc rpms which is why you got the error in your last post. What you should have done is
    Code:
    $rpm -qa | grep -i glibc
    A list of glibc related packages and their versions will be listed. Download and install the glibc-devel package that matches the version of glibc you have on your system

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4
    Quote Originally Posted by daark.child
    Did you notice that you are mixing 64 bit and 32 glibc rpms which is why you got the error in your last post. What you should have done is
    Code:
    $rpm -qa | grep -i glibc
    A list of glibc related packages and their versions will be listed. Download and install the glibc-devel package that matches the version of glibc you have on your system
    Thisis what I get with rpm -qa

    # rpm -qa | grep -i glibc
    glibc-2.3.4-2
    glibc-kernheaders-2.4-9.1.87
    glibc-2.3.4-2
    glibc-headers-2.3.4-2
    glibc-common-2.3.4-2
    glibc-devel-2.3.4-2


    I need to install an rpm that will give me the 32 bit version of /usr/lib/crt*

    Someone suggested glibc-devel-2.3.2-95.20.i386 but obviously this idea does not work.

    Would a reinstall of RHEL4 get me the 32 bit version of the lib?

  7. #6
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    I have the 32 bit version of CentOS 4.x which is rebuild of RHEL and glibc-devel provides the files you want.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •