Find the answer to your Linux question:
Results 1 to 7 of 7
I've had Apache set up for some time now, and the test page works fine, but I can't upload files to it... DocumentRoot = "/var/www/html" but for some reason, in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    109

    Question Apache issues...


    I've had Apache set up for some time now, and the test page works fine, but I can't upload files to it...

    DocumentRoot = "/var/www/html"

    but for some reason, in my FTP client, I can only see /var....the www and html directories are there, but something is keeping me from seeing them...

  2. #2
    Linux Newbie
    Join Date
    Dec 2006
    Posts
    105
    Please contact server admin for details. They will surely help you out...
    Unix, Linux tips...

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    54
    could it be your FTP Client hiding those folders from you?? just a guess..

  4. #4
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    109

    Question

    I am the server admin, granted I'm new to Linux though.

    /var/www/html is chmod 0777 (I even tried 7777) any other ideas??


    VSFTPD CONF FILE:
    # Example config file /etc/vsftpd/vsftpd.conf
    #
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    #
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    #
    # Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    anonymous_enable=NO
    #
    # Uncomment this to allow local users to log in.
    local_enable=YES
    #
    # Uncomment this to enable any form of FTP write command.
    write_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    local_umask=022
    #
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    #anon_upload_enable=YES
    #
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    #anon_mkdir_write_enable=YES
    #
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES
    #
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    #chown_uploads=YES
    #chown_username=whoever
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    #xferlog_file=/var/log/vsftpd.log
    #
    # If you want, you can have your log file in standard ftpd xferlog format
    xferlog_std_format=YES
    #
    # You may change the default value for timing out an idle session.
    #idle_session_timeout=600
    #
    # You may change the default value for timing out a data connection.
    #data_connection_timeout=120
    #
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    #nopriv_user=ftpsecure
    #
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    #async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that on some FTP servers, ASCII support allows a denial of service
    # attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
    # predicted this attack and has always been safe, reporting the size of the
    # raw file.
    # ASCII mangling is a horrible feature of the protocol.
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    #
    # You may fully customise the login banner string:
    ftpd_banner=Welcome to ftp.the24hourshow.net!
    #
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #deny_email_enable=YES
    # (default follows)
    #banned_email_file=/etc/vsftpd/banned_emails
    #
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    #chroot_local_user=YES
    chroot_list_enable=YES
    # (default follows)
    chroot_list_file=/etc/vsftpd/chroot_list
    #
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    ls_recurse_enable=YES
    #
    # When "listen" directive is enabled, vsftpd runs in standalone mode and
    # listens on IPv4 sockets. This directive cannot be used in conjunction
    # with the listen_ipv6 directive.
    listen=YES
    background=YES
    #
    # This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
    # sockets, you must run two copies of vsftpd whith two configuration files.
    # Make sure, that one of the listen options is commented !!
    #listen_ipv6=YES

    pam_service_name=vsftpd
    userlist_enable=YES
    tcp_wrappers=YES

    #added to use local time instead of GMT
    use_localtime=YES

    #added to access /var/www/html
    local_root=/var/www/html

  5. #5
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    109

    Question

    I reinstalled vsftpd and it worked, but when I restarted the server to make sure it would still work, this is what I got when I tried to ftp localhost

    Connected to the24hourshow.
    220 localhost.localdomain FTP server (Version 5.60) ready.
    334 Using authentication type GSSAPI; ADAT must follow
    GSSAPI accepted as authentication type
    GSSAPI error major: Unspecified GSS failure. Minor code may provide more information
    GSSAPI error minor: No credentials cache found
    GSSAPI error: initializing context
    GSSAPI authentication failed
    334 Using authentication type KERBEROS_V4; ADAT must follow
    KERBEROS_V4 accepted as authentication type
    Kerberos V4 krb_mk_req failed: You have no tickets cached

    I've never seen this before, and it would let me log in even though I know the user/pass was right...ideas??

  6. #6
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    109
    OK, I'm sorry that this went kind of haywire, but I figured out what went wrong

    in the builddefs.h file I removed the # where it defined the pam connection...whoops...I was thinking perl not C/C++

    I fixed that and I no longer have that error, now the problem is that when I try to login it tells me the password is incorrect...I know the password is right, but I believe that it needs to md5 the passwords before authentication...because my passwd file shows up like

    dsartain:$1$.VqfdUTV$YkOmOHBWBqtH8piNyVeqo/:500:500:Don Sartain:/home/dsartain:/bin/bash
    Any ideas on where to look for this one??

  7. #7
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    109

    Thumbs up

    RESOLVED!

    I had the /etc/pam.d/vsftpd file as /etc/pm.d/ftp

    I made that correction and now I'm up and running.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •