Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
it means you are plugging Second disk as Primary Master and BIOS booting up from Second disk. plug-in second disk as Secondary and make sure that fist disk is selected ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729

    it means you are plugging Second disk as Primary Master and BIOS booting up from Second disk. plug-in second disk as Secondary and make sure that fist disk is selected as First Boot Device in BIOS.








    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  2. #12
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62
    Casper
    thanks for your patience. Sorry this goes on a bit.

    My BIOS does not allow me to choose between the two sata drives for booting. My BIOS boot options are
    on-board USB or CD-rom
    on-board SATA hard drive
    on-board or usb floppy drive
    on-board IDE drive (not present)
    USB device (not present).

    My motherboard has two sata slots, sata0 and sata2. The data cable for the "old" drive was connected to sata0. I connected the data cable for the new drive to sata2 - as per the PC manual.

    Since I cannot change the BIOS options, I reversed the two data cables and tried booting. I got the same format (ubuntu) screen but the menu.lst contained just the entry for Fedora - possibly the entry I set up last night when trying to correct this. When I then selected Fedora it failed error 15.

    I looked at the boot options (F12) on the Dell screen.
    One option - drive diagnostics - showed my old drive as dr1 and the new drive as dr0.
    another option was "boot from utility partition" (?) I tried this and gor the same menu.lst as before I switched the cables. It just gives me "GRUB" if I select PCLinuxOS (on the new drive). I can boot into Fedora (on the old drive - I'm in it now with the cables still switched) but Fedora thinks I am using sdb and fdisk -l shows sdb only.

    Since my Bios does not allow choice between the two sata drives, and since I had the drives connected as per the PC manual, I don't see how this can be a wrongly plugged drive.

    I am going to switch the cables back since that seems not to be the problem.

    Your theory, as I understand it, is that there is an "old" Grub / device map in the MBR. I suppose I could
    - back up everything
    - Get into XP recovery console and use FIXMBR to reset MBR
    - remove boot files from /data/boot
    - Use fed6 rescue disk to set up the chainloader boot structure again.

    Would that fix it do you think?
    Or do you have any other suggestions before I do this?

    Again, my thanks for your help on this.

    nomadic

  3. #13
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62
    Casper
    ignore my comment about fdisk -l only showing sdb. I think it probably showed sda also but my terminal window was too small to see it.

    nomadic

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62

    Did I live such a bad life to deserve this????

    Casper
    In an attempt to move this forward here is what i've done

    first my current situation.
    I have the chainloading setup working fine on the old sda (motherboard sata0). I have XP, Fed6 and Suse10.2 on sda, together with swap partition and data partition which has /data/boot where the chainloader is stored. I can use these 3 systems with no problem whatever.

    I now also have the new sdb (motherboard sata2). This drive has PCLinuxOS on sdb5 and Ubuntu on sdb6 - I installed these just to prove the chainloading setup with the second drive. Each has it's grub bootloader in the root partition. Trying to boot these with the chainloader gets the word "Grub" and it is obviously waiting / looking for something.

    What I did to try to advance this
    I decided to set up the chainloading setup from scratch again. In other words, fix it so that only XP was in the MBR and then install a distro, set up the booting setup as per Whitely / VMunzo again - just as I did when I first set up this system.

    I backed everything up. I booted from my XP installation cd, went into recovery console, and issued Fixmbr - to clear out any grub files in MBR.
    I booted and proved that only XP was available.

    I then installed Ubuntu on sda10, and let it put grub into hd0.
    As per Whitely/VMunoz setup, I then copied the boot files from /boot/grub to data/boot.
    I then issued the command "Grub" and used "install ......" to point Grub at the files in /data/boot.
    I used "grub-install /dev/sda10" to put Grub into Ubuntu's root partition.
    I edited /data/boot/menu.lst by putting in my chainloader entries for XP and ubuntu and the other 2 distros I have.
    This was exactly how I set up the system I have now and which is working perfectly on the one drive (sda).

    I verified the device-maps of the three distros - all had hd0 and hd1.
    All of the above went without error.

    When I rebooted, it put me straight into grub (command line). grub>
    I had a look at the Grub commands available to me but I could not see how they were going to get me anywhere.

    Previously I was getting problems accessing a distro on the second drive. All of this setup here which failed was using the first drive only!!!!!!!!!!.
    Not alone am I not going forwards, I seem to be going backwards!!!!!!!!!!!


    I rolled everything back to where I had started.
    My one-drive chainloader is working fine. I can load XP, Fed6 and Suse again. for the moment, I have set the second drive (sdb) OFF in the BIOS.

    I'm out of ideas with this.
    If there is an old Grub in there looking for it's files, why has it not been removed by what I have done?
    - I reset MBR with Fixmbr.
    - I put ubuntu Grub into mbr. I verified that Ubuntu had hd0 and hd1 in device.map. So MBR should have had a valid Grub.
    - I copied Ubuntu's boot files into /data/boot, so those files should have been valid.

    I have connected up the new drive exactly as per the PC manual said.
    My BIOS does not allow the choice of which sata drive to boot from - I understand it always uses sata0.

    ????????????????????????????

    Three items before I batter this PC to death:
    1. Is there any other way of getting rid of an old Grub, assuming that is the problem? I thought the above approach would have done so but obviously not.

    2. Is there any possibility that something went wrong in setting up the second drive? Is there any file / diagnostic I could look at to show that this drive is properly set up / initialised / formatted?

    3. Is there any possibility that (apart from grub) that with all this messing about that I have done something to the old drive? Is there any file / diagnostic I could look at to make sure that drive is ok?

    (I get no errors from either drive)

    I will not be able to get back to this for a few days. If you (or anyone else) have any further thoughts they will be most welcome.

    nomadic

  6. #15
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62

    this thread no longer current

    Can't spend any more time trying to identify cause of this problem.
    Better use of my time to reset up my system.

    nomadic

  7. #16
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Everything is correct theoretically but its not working practically. problem is hardware related only. try to use default options. install GRUB in MBR. dont copy conf files or chainload. all Installers recognize other installed distros and add their entries in GRUB configuration file. Fedora Core's installer is the only exception. it doesn't recognize other installed Linux Distros.






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #17
    Linux Newbie
    Join Date
    Jan 2007
    Posts
    110
    It is my experience with an older version of Grub chainloading a newer Grub the following commands may give error
    Code:
    title PCLinusOX
    chainloader (hd1,4)+1
    The error can disappear if the same chainloader command is split into into two lines as follow
    Code:
    title PCLinusOX
    root (hd1,4)
    chainloader +1
    You can prove it yourself by pressing "c" at the moment the Grub booting screen appears so as to drop into a Grub prompt, as PCLinuxOS can be booted manually by
    [code]
    Code:
    root (hd1,4)
    chainloader +1
    boot
    To boot any system manually you use the same commands in menu.lst (or grub.conf if it is a Red Hat), omit the "title" statement and finish off with the "boot" statement (marked red in above).

    My recommendation to anybody having a problem with Grub is to boot the troubled system "manually". If you find the commands that work in manual booting they will work in menu.lst. In manual booting you can do it repeatedly by trial and error because Grub seldom hangs.

    Cut out the middleman, deal with Grub directly

  9. #18
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62

    Eureekaaaaaaaaaaaaaaaaaaaaa

    Saikee
    (hope you are not snowed in - I got out of Heathrow late last night and probably just in time).

    The change to the boot commands you suggested did the trick !!!!!!!!!!!
    I was able to load the two OS (PCLinuxOS and Ubuntu) which I had installed on the second drive to prove this booting setup.

    I was going nuts with this. Everything seemed to be set up ok. Many thanks - my next step was to clear my system and start again, so you saved me a lot of work.

    Thanks also to you casper - it is not the first time you helped me out.

    Now, back to doing some productive work.

    This thread is now closed.

    nomadic

  10. #19
    Linux Newbie
    Join Date
    Jan 2007
    Posts
    110
    Casper,

    I wrote

    Cut out the middleman, deal with Grub directly
    not knowing you and I were the midllemen now being cut out.

    nomadic now dealt with Grub directly and sorted out his problem. He has no need of us.


    I cut my own throat and you have been made redundant!

    Sorry for my big mouth again.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •