Find the answer to your Linux question:
Results 1 to 6 of 6
hiii i am using fc6. i was trying to install mplayer using the command # yum install mplayer mplayer-skins mplayer-plugins mplayer-gui however it showed the following error after running transaction ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4

    Thumbs down Transaction Test Error


    hiii
    i am using fc6. i was trying to install mplayer using the command
    # yum install mplayer mplayer-skins mplayer-plugins mplayer-gui
    however it showed the following error after running transaction test.

    running transaction test
    transaction test error


    file /usr/lib/libavutil.so.49 from install of ffmpeg-0.4.9-0.25.20061030.lvn6 conflicts with file from package libavutil49-0.4.9-19_r7407.fc6.at
    file /usr/lib/libavcodec.so.51 from install of ffmpeg-0.4.9-0.25.20061030.lvn6 conflicts with file from package libavcodec51-0.4.9-19_r7407.fc6.at
    file /usr/lib/libpostproc.so.51 from install of ffmpeg-0.4.9-0.25.20061030.lvn6 conflicts with file from package libpostproc51-0.4.9-19_r7407.fc6.at


    even after that i tried to re-install ffmpeg and it showed the same error.
    # rpm -ivh ffmpeg-0.4.9-0.25.20061030.lvn6.i386.rpm
    Preparing... ########################################### [100%]
    file from package libavutil49-0.4.9-19_r7407.fc6.at
    file /usr/lib/libavcodec.so.51 from install of ffmpeg-0.4.9-0.25.20061030.lvn6 conflicts with file from package libavcodec51-0.4.9-19_r7407.fc6.at
    file /usr/lib/libpostproc.so.51 from install of ffmpeg-0.4.9-0.25.20061030.lvn6 conflicts with file from package libpostproc51-0.4.9-19_r7407.fc6.at

    i think i hav added symbolic links between the above files using ln -s command. but i dont know how to proceed further and install mplayer.

    i also tried to uninstall ffmpeg libavutils libavcodec n all but it said the packages were not installed.

    [root@localhost software]# rpm -e ffmpeg-0.4.9-0.24.20060817.lvn6.i386.rpm
    error: package ffmpeg-0.4.9-0.24.20060817.lvn6.i386.rpm is not installed
    [root@localhost software]# rpm --erase libavutil49-0.4.9-19_r7407.fc6.at.i386.rpm
    error: package libavutil49-0.4.9-19_r7407.fc6.at.i386.rpm is not installed


  2. #2
    Linux Newbie
    Join Date
    Jan 2007
    Location
    Cupertino, CA
    Posts
    157
    Looks like you have some packages installed from the ATRPMS repository. If you want to get rid of these, try

    rpm -e libavutil49
    or
    rpm -e libavutil49-0.4.9-19_r7407.fc6.at

    Note the missing .rpm at the end (its an installed package and not a file).

    Similarly uninstall the other 2 conflicting packages.

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4

    Thumbs down transaction test error

    thanks for the reply.
    however i dint wanna uninstall the files. i wanted to install mplayer. but i think i had insertted some symbolic links between the files using ln -s command.... and so i am getting the transaction test error while installing mplayer using yum. here are the details.
    ================================================== ==============[root@localhost ~]# yum install mplayer mplayer-skins mplayer-fonts mplayerplug-in mplayer-gui

    Loading "installonlyn" plugin
    Setting up Install Process
    Setting up repositories
    livna 100% |=========================| 1.1 kB 00:00
    core 100% |=========================| 1.1 kB 00:00
    updates 100% |=========================| 1.2 kB 00:00
    freshrpms 100% |=========================| 1.1 kB 00:00
    extras 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    ...
    ...
    ...
    running transaction test
    transaction test error


    file /usr/lib/libavutil.so.49 from install of ffmpeg-0.4.9-0.25.20061030.lvn6 conflicts with file from package libavutil49-0.4.9-19_r7407.fc6.at
    file /usr/lib/libavcodec.so.51 from install of ffmpeg-0.4.9-0.25.20061030.lvn6 conflicts with file from package libavcodec51-0.4.9-19_r7407.fc6.at
    file /usr/lib/libpostproc.so.51 from install of ffmpeg-0.4.9-0.25.20061030.lvn6 conflicts with file from package libpostproc51-0.4.9-19_r7407.fc6.at
    ================================================== ===================
    rpm -e libavutil49-0.4.9-19_r7407.fc6.at
    error: Failed dependencies:
    libavutil.so.49 is needed by (installed) libavcodec51-0.4.9-19_r7407.fc6.at.i386
    libavutil.so.49 is needed by (installed) libpostproc51-0.4.9-19_r7407.fc6.at.i386
    libavutil.so.49 is needed by (installed) xine-lib-extras-nonfree-1.1.4-1.lvn6.i386

  4. #4
    Linux Newbie
    Join Date
    Jan 2007
    Location
    Cupertino, CA
    Posts
    157
    Which links did you create? Why not remove those links and try to install your packages then?

  5. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4

    Thumbs down

    hii
    but thats what i intended to ask... i was loooking at the man page of (ln) but i could not find any help for deleting the links i made... if you could help me in this regard.
    the following are the various symbolic links i created.

    ln -s /usr/local/lib/libstdc++.so.5 /usr/lib/libstdc++.so.5
    ln -s /usr/local/lib/libgcc_s.so.1 /usr/lib/libgcc_s.so.1
    ln -s /usr/local/lib/libgcc_s.so.1 /usr/lib/libgcc_s.so.1
    ln -s /usr/local/libstdc++.so.5 /usr/lib/libstdc++.so.5
    ln -s /usr/local/libstdc++.so.5 /usr/lib/libstdc++.so.5
    ln -s /usr/local/RealPlayer/libstdc++.so.5 /usr/lib/libstdc++.so.5
    ln -s /usr/lib/libstdc++.so.5 /usr/local/RealPlayer/libstdc++.so.5
    ln -s /usr/lib/libstdc++.so.5 /usr/local/RealPlayer/libstdc++.so.5

  6. #6
    Linux Newbie
    Join Date
    Jan 2007
    Location
    Cupertino, CA
    Posts
    157
    Symbolic Links are just special type of files. You remove them just as you remove files i.e using the rm command.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •