hi friends...

i am trying to install netscape in my centos linux

i donwloaded the latest version of netscape for linux compatability...
but when i try to run the ./netscape-installer

i get an error
error while loading shared libraries : libgtk-1.2.so.0: cannot open shared object file:no such file or directory...

i tried searching for that file on net (libgtk-1.2.so.0) but it give a downlaod as gtk+-1.2.10-7.i386.rpm
it give me warring as....
warning:gtk+-1.2.10-7.i386.rpm: V3 DSA signature: NOKEY, key ID f9651d5a
error: Failed dependencies:
iconv is needed by gtk+-1.2.10.10.1386

i need this to be done as soon as possible kindly help me i would apprciate if there could be fast response