Find the answer to your Linux question:
Results 1 to 9 of 9
Hi, I have the following: AMD 64 x2, ATI x1300 Pro, SATA hdd, 2gb ram pc It is all brand new, and I have installed Fedora 6 on it. After ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5

    Fedora 6 - Blank screen on load up


    Hi,

    I have the following:

    AMD 64 x2, ATI x1300 Pro, SATA hdd, 2gb ram pc

    It is all brand new, and I have installed Fedora 6 on it.

    After I installed it, it rebooted and get's past the graphical grub screen. It then goes fine until udev ------- OK and then the screen goes blank (no signal to the display).

    Any help would be much appreciated.

    Thanks

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi rhodesy22 !!

    Welcome to the LinuxForums.

    in GRUB screen, select Fedora title and press 'e'. select 'kernel' line, press 'e' again and add <space> 3 at the end of line. press 'Enter' key and press 'b' to boot up. this will drop you on command line login prompt. log in as root and execute this
    Code:
     system-config-display
    configure display and resolutions. in case your Monitor is not listed in Monitors List, select 'Generic' Monitor.
    reboot.




    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5
    Hi,

    Thanks for that,

    I did as you said, but I must have misconfigred as it said that X wouldn't start on that card. So I went back in so that I could re-do the configuration but again it says that X wouldn't start on the card.

    Any ideas?

    Thanks again

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    you have to edit xorg.conf manually. boot up in command line mode, login as 'root' and execute this
    Code:
    nano /etc/X11/xorg.conf
    look for Section "Device" 'Video Card' and set driver to "vesa".
    Code:
    Section "Device"
      identifier "xxxx Video Card"
      boardname "xxxx"
      busid "PCI:1:0:0"
      driver "vesa"
      screen 0
    EndSection
    save file and execute 'system-config-display' again. execute 'startx' to check GUI.






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5
    Thanks,

    The file doesn't exist though - when trying to edit it, it sets up a new file.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    are you executing correct command. Linux is case sensitive and X is capital in X11.
    Code:
    nano /etc/X11/xorg.conf






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5
    Section "Device"
    identifier "Videocard0"
    driver "radeon"
    EndSection

    I see only that, but I have changed radeon the vesa.

    I the tried to do the config however is came up with the X couldn't start on card 0 error again.

    Thanks

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    execute this
    Code:
    less /etc/X11/xorg.conf
    post the Section Monitor and Section Screen here.









    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5
    Section "Monitor"
    Identified "Monitor0"
    ModelName "LCD Panel 1024x768"

    HorizSync 31.5 - 48.5
    VertRefresh 40.0 - 70.0
    Option "dpms"
    EndSection


    Section "Screen"
    Identified "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "800x600" "640x480"
    EndSubsection
    EndSection



    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •