Find the answer to your Linux question:
Results 1 to 8 of 8
Two part question. Newly using Linux Fedora Core. 1. Editing GRUB boot loader. Upon booting PC, Linux Fedora Core splash screen appears, I have 3 seconds to press any key ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! spyderv1.2's Avatar
    Join Date
    Sep 2006
    Posts
    11

    Fedora Core/XP dual boot config & mounting secondary HDD


    Two part question. Newly using Linux Fedora Core.

    1. Editing GRUB boot loader.
    Upon booting PC, Linux Fedora Core splash screen appears, I have 3 seconds to press any key to get default boot options screen, from which I am successfully able to enter XP. I was just wondering if there is a way to automatically default to boot into boot options screen, instead of having to press a key to choose an Operating System. Picky, I know...I've only been able to alter this to a certain amount of time through the GRUB config GUI utility.

    2. I definitely can't seem to mount my secondary hard drive so that I can access it through Linux. I ran "cat /proc/partitions" and found that my secondary HDD is vfat, /dev/hdb. I created a folder inside of the root to read "Stuff". I then ran the following command in the terminal "mount -t vfat /dev/hdb /Stuff". Also, I modified /etc/fstab and inserted an entry to read:
    /dev/hdb /Stuff vfat defaults 1 1
    The problem I'm having is that upon entering the command into Terminal, I receive an error that too many filesystems/partitions exist on this hard drive. I have XP (one partition), and Linux as 3 seperate partitions, to include: "/", "swap", "/usr".

    here is the result of cat /proc/partitions:

    [root@localhost ~]# cat /proc/partitions
    major minor #blocks name

    3 0 39082680 hda
    3 1 9213246 hda1
    3 2 7164990 hda2
    3 3 16563015 hda3
    3 4 1 hda4
    3 5 5116671 hda5
    3 64 245117376 hdb
    3 65 1 hdb1
    3 69 245103673 hdb5

    Here is the result when I try mount -t vfat /dev/hdb /Stuff:

    [root@localhost ~]# mount -t vfat /dev/hdb /Stuff
    mount: wrong fs type, bad option, bad superblock on /dev/hdb,
    or too many mounted file systems

    I also tried to mount hdb5, with the same result. I also tried to mount hdb1, with a slightly different result, as if it were trying to hint something at my noob brain that I couldn't comprehend...

    [root@localhost ~]# mount -t vfat /dev/hdb1 /Stuff
    mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
    or too many mounted file systems
    (aren't you trying to mount an extended partition,
    instead of some logical partition inside?)

    Any help on this matter is greatly appreciated!

  2. #2
    Linux User
    Join Date
    Aug 2006
    Location
    Croydon, PA
    Posts
    392
    Post the out out put of fdisk -l and sfdisk -l.
    Good Luck,
    Ski
    RHCT

  3. #3
    Just Joined! spyderv1.2's Avatar
    Join Date
    Sep 2006
    Posts
    11
    Quote Originally Posted by Skiboy
    Post the out out put of fdisk -l and sfdisk -l.
    [root@localhost ~]# fdisk -l

    Disk /dev/hda: 40.0 GB, 40020664320 bytes
    255 heads, 63 sectors/track, 4865 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 1 1147 9213246 83 Linux
    /dev/hda2 1148 2039 7164990 82 Linux swap
    /dev/hda3 * 2803 4864 16563015 7 HPFS/NTFS
    /dev/hda4 2040 2802 6128797+ 5 Extended
    /dev/hda5 2040 2676 5116671 83 Linux

    Partition table entries are not in disk order

    Disk /dev/hdb: 251.0 GB, 251000193024 bytes
    255 heads, 63 sectors/track, 30515 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hdb1 * 2 30515 245103705 f W95 Ext'd (LBA)
    /dev/hdb5 2 30515 245103673+ 7 HPFS/NTFS

    [root@localhost ~]# sfdisk -l

    Disk /dev/hda: 77545 cylinders, 16 heads, 63 sectors/track
    Warning: extended partition does not start at a cylinder boundary.
    DOS and Linux will interpret the contents differently.
    Warning: The partition table looks like it was made
    for C/H/S=*/255/63 (instead of 77545/16/63).
    For this listing I'll assume that geometry.
    Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

    Device Boot Start End #cyls #blocks Id System
    /dev/hda1 0+ 1146 1147- 9213246 83 Linux
    /dev/hda2 1147 2038 892 7164990 82 Linux swap
    /dev/hda3 * 2802 4863 2062 16563015 7 HPFS/NTFS
    start: (c,h,s) expected (1023,254,63) found (1023,0,1)
    /dev/hda4 2039 2801 763 6128797+ 5 Extended
    /dev/hda5 2039+ 2675 637- 5116671 83 Linux
    Warning: start=63 - this looks like a partition rather than
    the entire disk. Using fdisk on it is probably meaningless.
    [Use the --force option if you really want this]

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by spyderv1.2
    1. Editing GRUB boot loader.
    Upon booting PC, Linux Fedora Core splash screen appears, I have 3 seconds to press any key to get default boot options screen, from which I am successfully able to enter XP. I was just wondering if there is a way to automatically default to boot into boot options screen, instead of having to press a key to choose an Operating System. Picky, I know...I've only been able to alter this to a certain amount of time through the GRUB config GUI utility.
    login as root and open /boot/grub/grub.conf file. look for line 'hiddenmenu'. put # sign before it. GRUB menu will appear without press any key on next boot.

    2. Fedora doesn't support NTFS read access out of box. install kmod-ntfs to enable NTFS read access.
    Code:
    yum -y install kmod-ntfs
    for NTFS read/write access, check this link.





    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined! spyderv1.2's Avatar
    Join Date
    Sep 2006
    Posts
    11
    Quote Originally Posted by devils_casper
    login as root and open /boot/grub/grub.conf file. look for line 'hiddenmenu'. put # sign before it. GRUB menu will appear without press any key on next boot.

    2. Fedora doesn't support NTFS read access out of box. install kmod-ntfs to enable NTFS read access.
    Code:
    yum -y install kmod-ntfs
    for NTFS read/write access, check this link.





    Casper
    I successfully altered GRUB...so we've got that one knocked out. I'm still having problems with the secondary HDD. I tried 3 different commands in Terminal to allow NTFS, but none worked. Here is the result:

    [root@localhost ~]# yum -y install kmod-ntfs
    Setting up Install Process
    Setting up Repos
    base 100% |=========================| 1.1 kB 00:00
    updates-released 100% |=========================| 951 B 00:00
    Reading repository metadata in from local files
    base : ################################################## 2622/2622
    updates-re: ################################################## 910/910
    Parsing package install arguments
    No Match for argument: kmod-ntfs
    Nothing to do

    **********************
    [root@localhost ~]# yum -y install ntfs
    Setting up Install Process
    Setting up Repos
    http://fedora.gtlib.cc.gatech.edu/pu...ta/repomd.xml: [Errno 4] IOError: HTTP Error 404: Not Found
    Trying other mirror.
    base 100% |=========================| 1.1 kB 00:00
    http://fedora-mirror.dkuug.dk/linux/...ta/repomd.xml: [Errno 4] IOError: HTTP Error 404: Not Found
    Trying other mirror.
    updates-released 100% |=========================| 951 B 00:00
    Reading repository metadata in from local files
    base : ################################################## 2622/2622
    updates-re: ################################################## 910/910
    Parsing package install arguments
    No Match for argument: ntfs
    Nothing to do

    ***********************

    [root@localhost ~]# yum -y install ntfs3-g
    Setting up Install Process
    Setting up Repos
    base 100% |=========================| 1.1 kB 00:00
    updates-released 100% |=========================| 951 B 00:00
    Reading repository metadata in from local files
    base : ################################################## 2622/2622
    updates-re: ################################################## 910/910
    Parsing package install arguments
    No Match for argument: ntfs3-g
    Nothing to do

    *****

    So, all seem to have produced an error result. As in fact seemingly proved by this output:

    [root@localhost ~]# mount -t ntfs /dev/hdb /Stuff
    mount: fs type ntfs not supported by kernel

    Any ideas?

  7. #6
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    You need the Livna repo enabled

    As root
    rpm -Uvh http://www.fedorafaq.org/yum http://rpm.livna.org/livna-release-6.rpm

    Check this for a lor of useful stuff http://www.fedorafaq.org
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  8. #7
    Just Joined! spyderv1.2's Avatar
    Join Date
    Sep 2006
    Posts
    11
    Fixed!

    I had to download and install FUSE http://fuse.sourceforge.net/ before I could get NTFS-3G to properly install...which I still couldn't do through terminal with yum. I got it from http://wiki.linux-ntfs.org/doku.php?id=ntfs-3g and used the instructions on that page to mount the drive. Also, turns out my secondary HDD is /dev/hdb5...

    Thanks very much to everyone who contributed...this seriously feels like a great accomplishment...so much that I got up and danced when I found it was successful...lol.

    Again, thanks!

    -Spyder

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Well Done !!






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •