Find the answer to your Linux question:
Results 1 to 3 of 3
I've having trouble with this node that keeps outputing incorrect dates whenever I login to it. Sometimes it will display the correct information, but more times than not it's incorrect. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4

    Wacky date ouput


    I've having trouble with this node that keeps outputing incorrect dates whenever I login to it. Sometimes it will display the correct information, but more times than not it's incorrect. Here's what I see. I have reset ntp a couple of times but errors return after a while.

    Last login: Wed Aug 28 21:44:00 2002 from head.local ***incorrect
    pc1:~ # date
    Mon Feb 12 06:56:17 CST 2007 ***Correct
    pc1:~ # exit
    logout
    Connection to pc1 closed.
    opteronhead:~ # ssh pc1
    Last login: Mon Feb 12 06:56:14 2007 from head.local ***correct
    pc1:~ # date
    Sun Mar 1 14:25:13 CST 586561 ***incorrect
    pc1::~ # exit
    logout
    opteronhead:~ # ssh pc1
    Last login: Sat Aug 31 13:59:50 2002 from head.local ***incorrect
    pc1::~ # date
    Mon Feb 12 06:56:46 CST 2007

    Anyone have any ideas to what would be causing this?

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    15

    Have you tried doing the "rdate" command?

    I'm a n00b so you might want to disregard my posting if you've already done this. I've had problems in the past with keeping time and this helps me sync up time normally:

    rdate time.nist.gov <cr>

    Also another note; this problem you might be experiencing might NOT be software. I run old hardware and sometimes have to install a new CMOS battery to remedy clock settings that drift. Have you tried that? There might be other avenues to troubleshoot but ALWAYS keep it simple; at least in the beginning before you go crazy modifying this and that. Good luck!

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4
    Thanks, I will try those steps out next time. Actually the computer just crashed from a power outage. I guess it's a lost cause now, but thanks anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •