Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, I have the following in the /etc/fstab server01:/vol/tune /tune nfs rw,bg,hard,nointr,proto=tcp,vers=3,rsize=32768,wsi ze=32768,timeo=600 0 0 server01:/vol/dba /dba nfs rw,bg,hard,nointr,proto=tcp,vers=3,rsize=32768,wsi ze=32768,timeo=600 0 0 server01:/vol/install /install nfs rw,bg,hard,nointr,proto=tcp,vers=3,rsize=32768,wsi ze=32768,timeo=600 0 0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    6

    NFS not remounting on reboot


    Hello all,

    I have the following in the /etc/fstab
    server01:/vol/tune /tune nfs rw,bg,hard,nointr,proto=tcp,vers=3,rsize=32768,wsi ze=32768,timeo=600 0 0
    server01:/vol/dba /dba nfs rw,bg,hard,nointr,proto=tcp,vers=3,rsize=32768,wsi ze=32768,timeo=600 0 0
    server01:/vol/install /install nfs rw,bg,hard,nointr,proto=tcp,vers=3,rsize=32768,wsi ze=32768,timeo=600 0 0

    After reboot only the /install file system is mounted. However, If I run /etc/init.d/netfs after the reboot is complete then all nfs are mounted fine.

    I'm mounting to a NetApp filer and the /etc/fstab is setup the same as on another Linux machine that boots and mounts fine. One difference is the one that doesn't work is 64 bit.

    Does anyone have an idea of what is going on or a way I can solve this problem? Is there a log I can look at? Did I do something wrong?

    Thanks,
    Michael

  2. #2
    Linux Enthusiast likwid's Avatar
    Join Date
    Dec 2006
    Location
    MA
    Posts
    649
    Try adding auto to the options. If it still doesn't work after that, try the _netdev option in addition.

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    6
    My problem has been resolved. The problem was that when the /etc/init.d/netfs file was executed the network was not configured completely. So Redhat support had me add a "sleep 30" just before the final "exit 0" command in the /etc/init.d/network file. It now looks like this:

    sleep 30
    exit 0
    ~

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •