Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 30 of 30
nano -w to disable word wrap. I would NOT do that until learn a little more......
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Feb 2007
    Posts
    41

    nano -w

    to disable word wrap. I would NOT do that until learn a little more...

  2. #22
    Just Joined!
    Join Date
    Feb 2007
    Posts
    15
    I've messed it up!

    Just from quriosity i wanted to try this and now my linux won't boot up.

    I've edited the grub.conf file with nano /boot/grub/grub.conf

    and i replaced this line:
    kernel /vmlinuz-2.6.17.11-1.1.x86... ro root=LABEL=/1 quiet

    with
    kernel /vmlinuz-2.6.17.11-1.1.x86... ro root=LABEL=/vga=792 quiet

    after that i saved the changes and reboot, and from then on i get:
    Error 11: Unrecognized device string

    I've tried to get back the old code by "e to edit the commands before booting" but everytime i get the same message now. I've tried:
    LABEL=/1 quiet
    LABEL=/ 1 quiet
    LABEL=/1
    LABEL=/ 1
    LABEL=\1 quiet
    LABEL=/vga=792 quiet
    LABEL=/vga=792
    LABEL=/ vga=792

    everytime i get the same message.
    Error 11: Unrecognized device string

  3. #23
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    there should be a <space> between root=LABEL=/ and vga=792.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #24
    Just Joined!
    Join Date
    Feb 2007
    Posts
    15
    I've tried that. I will reinstall everything

  5. #25
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I've tried that. I will reinstall everything
    thats upto you. i dont think you need to do that. edit kernel line correctly and you are good to go.
    Code:
    kernel /vmlinuz-2.6.17.11-1.1.x86... ro root=LABEL=/ quiet




    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #26
    Just Joined!
    Join Date
    Feb 2007
    Posts
    15
    hmmm this might be the problem. After a full restart i see that the line is still the same from my first edit. LABEL=/vga=792 quiet

    It seems that all the other changes i tried are not saved somehow?

    on the bootup there is a option to try to edit the commands before bootting. I go for this by pressing 'e'. After pressing 'e' i got a table with four lines only:

    root (hd0,0)
    kernel /vmlinuz-2.6.17.11-1.1.x86.i686.cmov ro
    root=LABEL=/vga=792 quiet
    initrd /initrd-2.6.17.11-1.1.x86.i686.cmov.img

    i select the third line and i go for one more 'e' here, then i change the text to:
    root=LABEL=/ vga=792 quiet
    then enter and the 'b' to boot.

    Then i get the same error message this time with changed line LABEL=/ vga=792.. reported. But if i do a restart of the system, the error message is with the old line, LABEL=/vga=792.

    Why the change is not saved?

  7. #27
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    you are editing options at runtime not actual grub.conf file.
    boot up from Installation CD/DVD, execute 'linux rescue' at boot: prompt. this will drop you at shell prompt again.
    excute this
    Code:
    chroot /mnt/sysimage
    nano /boot/grub/grub.conf
    edit grub.conf, save it and reboot.







    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #28
    Just Joined!
    Join Date
    Feb 2007
    Posts
    15
    I've reinstalled the package and i saw that the original grub.conf does not have LABEL=/1 quiet but only LABEL=/ quiet

    I've added the vga=792 quiet and the system now works fine, only i cannot see any difference in the look of the linux.

    Ok, it does not matter, but while reinsalling this Asterisk package i saw that the distribution of Linux is actually a rPath Linux. Sound familliar?

  9. #29
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I've reinstalled the package and i saw that the original grub.conf does not have LABEL=/1 quiet but only LABEL=/ quiet

    I've added the vga=792 quiet and the system now works fine, only i cannot see any difference in the look of the linux.
    as i suggested you earlier, vga=792 wont make any difference.
    i would suggest you to check www.linuxcommand.org first.





    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #30
    Just Joined!
    Join Date
    Feb 2007
    Posts
    15
    thanx Casper, i will do that.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •