Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hi all, i have been trying to build linux kernel 2.6.9 with an rtlinux patch on the same, but i am getting the following error when i try to make ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie rinjo's Avatar
    Join Date
    Feb 2007
    Location
    Bangalore, India
    Posts
    228

    Unhappy ramdisk image creation problem


    Hi all,
    i have been trying to build linux kernel 2.6.9 with an rtlinux patch on the same, but i am getting the following error when i try to make the initrd file for the same.

    [root@localhost linux-2.6.9]# /sbin/mkinitrd /boot/initrd-2.6.9-rtlfree 2.6.9
    No module ata_piix found for kernel 2.6.9, aborting.

    I have checked in the kernel configuration, and have made sure that the ata_piix module is present in the same.

    can anyone tell me how to build a ramdisk image for the kernel.

    while booting the kernel gives a waring:
    Warning: Unable to open intial console


    Rinjo

  2. #2
    Linux User cyberinstru's Avatar
    Join Date
    Jan 2007
    Location
    India
    Posts
    362
    have you given any label to the newly compiled kernel?

    Can you list the directories present in /lib/modules directory?

    Can you check if you have the compiled module ata_pixx.ko in /lib/module/2.6.9/?

    while creating ramdisk, do mkinitrd -v ....

    So that more debug messages would appear
    ---------------------------------
    Registered Linux User #440311
    HI2ARUN _AT_ GMAIL _DOT_ COM
    ---------------------------------

  3. #3
    Linux Newbie rinjo's Avatar
    Join Date
    Feb 2007
    Location
    Bangalore, India
    Posts
    228

    Question

    Hi cyberinstru,

    thanks for replying. I have checked the details that you have mentioned.

    ata_piix.ko is not present in the /lib/modules/2.6.9 directory.

    when i use verbose option for in the mkinitrd call, it looks for dependcies on modules. The output is as follows:

    [root@localhost linux-2.6.9]# /sbin/mkinitrd -v /boot/inintrd-2.6.9-rtlfree 2.6.9
    Creating initramfs
    Looking for deps of module scsi_mod
    Looking for deps of module sd_mod
    Looking for deps of module unknown
    Looking for deps of module ata_piix
    No module ata_piix found for kernel 2.6.9, aborting.

    can be build the module without the ata_piix dependency? Will RTlinux work without it?

    Rinjo

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User cyberinstru's Avatar
    Join Date
    Jan 2007
    Location
    India
    Posts
    362
    Check for
    CONFIG_SCSI_ATA_PIIX
    in your
    .config
    file in kernel source directory.

    Set that to
    CONFIG_SCSI_ATA_PIIX=m
    and re-compile. It should work.

    this is required for SATA - IDE support
    ---------------------------------
    Registered Linux User #440311
    HI2ARUN _AT_ GMAIL _DOT_ COM
    ---------------------------------

  6. #5
    Linux Newbie rinjo's Avatar
    Join Date
    Feb 2007
    Location
    Bangalore, India
    Posts
    228
    I have made the changes in the .config and the ata_piix module has been built. The initrd*.img file has also been created.
    But I am still facing boot problems.
    These are the messages that i am getting:

    grub.conf contents:-
    title RTLinux (WhiteHope) (2.6.9rtlfree)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.9rtlfree ro root=LABEL=/ rhgb quiet
    initrd /boot/initrd-2.6.9rtlfree.img
    title PCQLinux 2005 (WhiteHope) (2.6.11-1.14_FC3)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.11-1.14_FC3 ro root=LABEL=/ rhgb quiet
    initrd /boot/initrd-2.6.11-1.14_FC3.img
    title Windows XP Professional
    rootnoverify (hd0,0)
    chainloader +1

    Err:
    hub 1-0:1-0: over current change port 7
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)

    grub.conf contents:-
    title RTLinux (WhiteHope) (2.6.9rtlfree)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.9rtlfree ro root=/dev/hda2
    initrd /boot/initrd-2.6.9rtlfree.img
    title PCQLinux 2005 (WhiteHope) (2.6.11-1.14_FC3)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.11-1.14_FC3 ro root=LABEL=/ rhgb quiet
    initrd /boot/initrd-2.6.11-1.14_FC3.img
    title Windows XP Professional
    rootnoverify (hd0,0)
    chainloader +1

    Err:
    VFS: Mounted root (ext3 filesystem) readonly
    Freeing unused kernel memory: 188k freed
    Warning: Unable to open ab initial console

    Note: I am using a 2.6.11 base kernel to build the 2.6.9 kernel with the RTlinux patch. 2.6.9 kernel is loaded on the /opt/rtl/linux-2.6.9 directory.

    please help.

  7. #6
    Linux User cyberinstru's Avatar
    Join Date
    Jan 2007
    Location
    India
    Posts
    362
    Can you post the output of
    cat /etc/fstab
    and that of
    cat /etc/mtab
    here?

    (I think Casper could be of some help to you in this regard - he has amazed me by his knwldge at linux boot loaders)
    ---------------------------------
    Registered Linux User #440311
    HI2ARUN _AT_ GMAIL _DOT_ COM
    ---------------------------------

  8. #7
    Linux Newbie rinjo's Avatar
    Join Date
    Feb 2007
    Location
    Bangalore, India
    Posts
    228
    contents of the files:

    [root@localhost ~]# cat /etc/fstab
    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    LABEL=/ / ext3 defaults 1 1
    none /dev/pts devpts gid=5,mode=620 0 0
    none /dev/shm tmpfs defaults 0 0
    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
    LABEL=SWAP-hda3 swap swap defaults 0 0

    /dev/hda1 /mnt/Windows vfat defaults,rw 0 0
    # ***Start Of PCQLinux mountfatpartitions enteries***
    /dev/hda1 /mnt/C: vfat defaults 0 0
    # ***End Of PCQLinux mountfatpartitions script enteries***
    /dev/hdc /media/cdrom auto pamconsole,exec,noauto,fscontext=system_u:object_r :removable_t,managed 0 0
    /dev/fd0 /media/floppy auto pamconsole,exec,noauto,fscontext=system_u:object_r :removable_t,managed 0 0


    [root@localhost ~]# cat /etc/mtab
    /dev/hda2 / ext3 rw 0 0
    none /proc proc rw 0 0
    none /sys sysfs rw 0 0
    none /dev/pts devpts rw,gid=5,mode=620 0 0
    usbfs /proc/bus/usb usbfs rw 0 0
    none /dev/shm tmpfs rw 0 0
    /dev/hda1 /mnt/Windows vfat rw 0 0
    /dev/hda1 /mnt/C: vfat rw 0 0
    none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
    sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0

    i hope that this will help.
    how can i get in touch with Casper?

  9. #8
    Linux User cyberinstru's Avatar
    Join Date
    Jan 2007
    Location
    India
    Posts
    362
    Well,

    title RTLinux (WhiteHope) (2.6.9rtlfree)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.9rtlfree ro root=/dev/hda2 rhgb quiet
    initrd /boot/initrd-2.6.9rtlfree.img
    title PCQLinux 2005 (WhiteHope) (2.6.11-1.14_FC3)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.11-1.14_FC3 ro root=LABEL=/ rhgb quiet
    initrd /boot/initrd-2.6.11-1.14_FC3.img
    title Windows XP Professional
    rootnoverify (hd0,0)
    chainloader +1
    should do.
    ---------------------------------
    Registered Linux User #440311
    HI2ARUN _AT_ GMAIL _DOT_ COM
    ---------------------------------

  10. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by rinjo
    Err:
    hub 1-0:1-0: over current change port 7
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)
    the hub message is coz of malfuntioning usb ports. try to unplug all usb devices or disable USB in BIOS. if you are not using hotplug then problem is in uhci_hcd and ohci_hcd modules.
    did you change anything in default .config?





    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    Linux Newbie rinjo's Avatar
    Join Date
    Feb 2007
    Location
    Bangalore, India
    Posts
    228
    Hi devils_casper, Thanks for replying!

    I tried using Cyberinstrus suggestion of changing the kernel path in the grub to:
    kernel /boot/vmlinuz-2.6.9rtlfree ro root=/dev/hda2 rhgb quiet
    But this did not help.

    I am not using any hot plugin devices, neither there are any USB devices attached to my system.

    The only change that i have made in the .config file is that i have disabled the Power management options and changed the SCSI config line to CONFIG_SCSI_ATA_PIIX=m.
    this was done as the ATA_PIIX module was not getting built.

    I am still getting the same error message when i boot.

    please help.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •