Find the answer to your Linux question:
Results 1 to 10 of 10
I have my system partitioned like this: (the sizes are estimates) 1.5 GB Primary1 Fat32 Win98 2 GB Primary2 NTFS WinXP 2 GB Primary3 Ext2 Fedora 5 GB Extended1 Ext3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Location
    Canada/Brazil
    Posts
    11

    Flawless Install, but where are my partitions and drives??


    I have my system partitioned like this:

    (the sizes are estimates)


    1.5 GB Primary1 Fat32 Win98
    2 GB Primary2 NTFS WinXP
    2 GB Primary3 Ext2 Fedora
    5 GB Extended1 Ext3 (future Mandrake)
    5 GB Extended2 FAT32 (Shared)
    95 GB Extended3 NTFS (Storage)

    Then an 80 GB NTFS with XP on it.

    All the operating systems installed work.

    I installed Fedora Core, Opened the file manager and went to /mnt
    All that was there was floppy and cdrom.
    So I opened up the Terminal and typed "mount /dev/hde2"
    It gave an error saying that its not found etc...
    I looked in /etc/fstab and no drives/partitions were listed except the floppy and cdrom.
    So I looked in the folder with all the drive labels in it (im a newbie, bear with me, i think it was /dev or /etc as Im in XP right now so i cannot look)
    It had hda hda1 hde1 etc.. and hundreds of other ones.
    So then in the Terminal I typed "fdisk -l"
    and It listed all the drives/partions, their filesystem, size etc...
    It showed that they were there and it named them hde1 hde2 hde3 etc...
    I tried everything i knew and could not mount them. How cna I access them??

    Thanx

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    In order to mount the other partitions, you need to add them to fstab. You can do it manually using any text editor or I believe there's a gui that you can use, or at least there is with Mandrake.

    After theyre added, you should be able to mount them.

    Good luck!
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Stockholm, Sweden
    Posts
    130
    If I understood you right, then your partitions are probably something like this :

    /dev/hda1 Win98
    /dev/hda2 WinXP
    /dev/hda3 Fedora
    /dev/hda5 Future Mandrake
    /dev/hda6 Fat32
    /dev/hda7 Storage

    you can use the mount command, although I strongly recommend adding them to your fstab.

    Try this :
    mkdir /mnt/win98
    mount -t vfat /dev/hda1 /mnt/win98

    and do the same with the rest, except change mountpoints, and types
    (which are specified with the -t option)

    also, you might experience errors like : "bad superblock, or wrong fs type, or too many filesystems mounted"

    all this means is that either
    a ) You have tried to use the wrong filesystem (for example, ntfs for a linux partition)
    b ) Your machine doesn't support the filesystem ( you might need to add support for vfat and/or ntfs)

    Hope it was of some help

    //ooop

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Location
    Canada/Brazil
    Posts
    11
    umm I will try this and get back to you.

    last time i booted into it it wouldnt allow me to use fdisk. It had a bash: for it.

  6. #5
    Just Joined!
    Join Date
    Apr 2004
    Location
    Canada/Brazil
    Posts
    11
    now for both fdisk and anything with -t in it it gives: "bash: fdisk: command not foung" and the same for -t.

    I cant do anything....


    very weird.

  7. #6
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    are you doing all of this as root?
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  8. #7
    Just Joined!
    Join Date
    Apr 2004
    Location
    Canada/Brazil
    Posts
    11
    It was working for both User and Root before...

    now I have tried both root and user again and it doesnt work.

    I havent done any major system changes and basically everything is still at default.

  9. #8
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    perhaps fdisk needs to be called with the absolute path, like so:

    Code:
    $/usr/sbin/fdisk
    Use:

    Code:
    $which fdisk
    to find it's location and try to use the enitre path.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  10. #9
    Just Joined!
    Join Date
    Apr 2004
    Posts
    1
    Maybe this is not the issue, but when working with large drives and different filesystems, also be aware of weird filesystem 'interference' (not easely noticeable). It's not well documented, but sometimes bios limitations may look like everything is ok, showing disk space correctly, and then the operating system finally try to write to sectors (usually in the end of the disk) that will end up overwriting sectors on another partition (usually in the begginning of the disk), destroying it.

    I experienced this about 6 months ago with a 32gig limited bios that seemed to recognize the 40g ide ata drive ok, and also had no problems partitioning and installing different operating systems. And i would never notice the issue, if hadn't tried to wipe free space on the partition in the end of the disk. I wonder how many people with large disks face the same issue months, maybe *years after partitioning their drives (and atributing the issue to something else without a clue of what exactly happened).

    Obviously, if this is the case, you will not be able to view/mount the offending filesystem(s) anymore.

  11. #10
    Just Joined!
    Join Date
    Nov 2003
    Posts
    5
    Hi,

    I personally use Webmin, http://www.webmin.com/download.html I relaly like it, nice GUI for the newbies like me who loves graphics! No excuses not to learn the commands, but Webmin works good and has some interesting features.

    Cheers!|

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •