Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all! I finally got FC2 on my system, after having to completely wipe out my FC1 system and install as apt-get yum or synaptic would not perform an upgrade ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    4

    CDCEther not working in FC2


    Hi all!

    I finally got FC2 on my system, after having to completely wipe out my FC1 system and install as apt-get yum or synaptic would not perform an upgrade correctly and made my system unbootable, and now I am unable to connect to the Internet on this system as when I am in Network Device Control and click the Activate button, I get the following report:



    Code:
    CDCEther device eth0 does not seem to be present, delaying initialization.
    Anyway, after the full installation, my /etc/modprobe.conf file looked like this:

    Code:
    alias usb-controller uhci-hcd
    alias eth0 CDCEther
    After doing some research on the Redhat board, I added the following line:

    Code:
    alias eth0 usbnet
    After I did this, I get the following error message:

    Code:
    CDCEther
    usbnet device eth0 does not seem to be present, delaying initialization
    Also, why I look in the System log for errors, I am getting the following errors:

    Code:
    kernel: usbnet: probe of 1-1:1.0 failed with error -22
    kernel: usb 1-1: string descriptor 0 read error: -75
    kernel: usbnet: probe of 1-1:1.0 failed with error -75
    To answer your questions, yes I am using USB to connect the the Internet. I have seen alot of people say that this is not how Linux was intended to connect to the Internet, but hey, it's all just data.... Anyway, this worked GREAT under FC1 with NO modifications. Also worked like a charm in RH9!

    Why would they change something suddenly that was working fine? Isn't there a rule in programming that says;

    "If it's not broken, don't fix it!"?

    Or maybe,

    "Don't add functionality to a module if it breaks the module's original functionality."?

    If there isn't, then there should be, especially the second one.

    I would like to know if anyone has any suggestions, other than go back to FC1, as to how I could resolve this issue. I really like the responsiveness of kernel 2.6, but do not care if I'm unable to connect to the Internet using FC2.

    Thanks in advance for all your time!

  2. #2
    Just Joined!
    Join Date
    May 2004
    Posts
    4
    Also, when I run an lsmod, CDCEther is not present. When I run a modprobe for CDCEther, I get:

    Code:
    FATAL: Module CDCEther not found.
    Thanks for your time!

  3. #3
    Just Joined!
    Join Date
    May 2004
    Posts
    4

    Nevermind...

    I found out that this was a hardware problem and resolved by buying a PCMCIA NIC card and installing.

    Thanks

    sax

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •