Find the answer to your Linux question:
Results 1 to 7 of 7
hii friends, i have freshly installed fedora-6. i've been using this successfully from past 2-3 days. but today when i restarted my machine a strange error occured. i've not done ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    3

    Red face x-session starting error


    hii friends,


    i have freshly installed fedora-6. i've been using this successfully from past 2-3 days. but today when i restarted my machine a strange error occured.

    i've not done any changes to the configuration of the system. when the OS gets started the log-in screen appears. after entering the login name:root and the password the following message comes in a message window with exclamation :

    " your session only lasted less than 10 seconds. If you have, not logged out yourself this could mean that there is some installation problem or that you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem.

    view details(~/.xsession-error file)

    localuser: root being added to access control list
    could'nt load exec gnome-session : No such file or directory.
    "


    even if i start a new session of KDE /GNOME the same error comes only that instead of gnome-session it is written kde-session.

    i dont know what to do with this.
    please help me solve this problem

    Thanks and Regards
    Shah Shamik

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Did you upgrade anything recently or change any settings? Also what happens when you login as a normal user(which you should always do instead of using the root account)?

  3. #3
    Linux Newbie unchiujar's Avatar
    Join Date
    Oct 2006
    Posts
    194
    I had the same problem several times with Fedora. It seems the problem is some gconf setting that gets messed up. I think you can fixed it by going in your home directory and deleting (or moving) the .gconf(2?) directory. Unfortunately this will erase all your customizations for Gnome.
    If you log in as root or some other user Gnome should start fine and you can move the directory from there. Or you can do it from the command line if you know how.

    I hope I remember this correctly, because I haven't used Fedora in a while.

    Alternatively, if this doesn't work you can try moving the entire user directory, creating a user with the same uid and name, and then copying directory by directory(overwrite) back in the new user directory to find out where the problem lies. That's how I found out about .gconf .
    Hope this helps.

  4. #4
    Just Joined!
    Join Date
    Apr 2007
    Posts
    3
    i've recently downloaded Qt4.2.3 from Trolltech's website and installed it at a custom folder /usr/local/qt and set the environment variables.

    else than this i've not made any changes to the system settings.

    secondly i cant log-in neither as root nor as any other user. as i told previously after the log-in screen immediately that messagebox comes and the log-in screen re-appears. so i cant log-in anyhow.

    as instructed in the previous post i've deleted the .gconf directory from /root folder by changing the session to fail-safe and logging in as root. then reboot.

    but this has also not worked.

    is there any other way that can start the session (Gnome/KDE)??

    according to me as the shown in the error message and in .xsession-error file : it is not able to load or execute the "gnome-session" or "kde-session" file which is present in /usr/bin folder.
    i think there must be something wrong with these binaries.
    wat say??

  5. #5
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    When you setup qt, did you edit the PATH variable in /etc/profile?

  6. #6
    Just Joined!
    Join Date
    Apr 2007
    Posts
    3
    yes
    i've added the following lines in profile file present in /etc folder

    QTDIR=/usr/local/qt
    PATH=/usr/local/qt
    LD_LIBRARY_PATH=/usr/local/qt/lib
    QTINC=/usr/local/qt/include
    MANPATH=/usr/local/qt/doc

    export QTDIR PATH LD_LIBRARY_PATH QTINC MANPATH


    but i dont think this can have any effect starting or loading the Gnome or KDE

  7. #7
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    PATH=/usr/local/qt
    Change it to
    Code:
    PATH=$PATH:/usr/local/qt
    After that try logging into KDE or GNOME.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •