Find the answer to your Linux question:
Results 1 to 3 of 3
Hi i am having a problem with proftpd on a FC5 system when i try to login the ftp client says incorrect login, when i know its 100% right so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    33

    ProFTPd wont login


    Hi

    i am having a problem with proftpd on a FC5 system

    when i try to login the ftp client says incorrect login, when i know its 100% right

    so i looked in the logs and i was getting the following message

    Code:
    May 14 11:46:45 92-81 proftpd[9151]: hostname (xxx.xxx.xxx.xxx[xxx.xxx.xxx.xxx]) - USER admin: Login successful. 
    May 14 11:46:45 92-81 proftpd[9151]: Hostname (xxx.xxx.xxx.xxx[xxx.xxx.xxx.xxx]) - notice: unable to use '~/' [resolved to '/home/']: Permission denied 
    May 14 10:46:45 92-81 proftpd[9151]: Hostname (xxx.xxx.xxx.xxx[xxx.xxx.xxx.xxx]) - Preparing to chroot to directory '~/' 
    May 14 10:46:45 92-81 proftpd[9151]: Hostname (xxx.xxx.xxx.xxx[xxx.xxx.xxx.xxx]) - admin chroot("~/"): No such file or directory 
    May 14 10:46:45 92-81 proftpd[9151]: Hostname (xxx.xxx.xxx.xxx[xxx.xxx.xxx.xxx]) - error: unable to set default root directory
    the permissons are set right on /home

    Code:
    drwxrwxrwx 16 admin admin 4096 May 14 12:02 /home
    i have tried vsftp and pure-ftp but non of them seem to allow me to login as admin or anyother user i added

    anyone got any ideas on how to fix this?

    Thanks

    David

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Location
    Adelaide, Australia
    Posts
    53
    Given the fact your home directory permissions are 777 proftpd may possibly be complaining about this as a security issue.. however I'm not completely sure..

    Code:
    drwxr-xr-x   18 root  root   4096 Mar  7 21:53 home
    These permissions should be adequate (755).

    Not only that check /etc/passwd and check teh users homedirectory, its a little unusual to have someones homedirectory being /home only...

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Location
    Plainsboro, NJ
    Posts
    16
    How exactly did you install and set up proftpd? Installed via RPM? If so, try removing it (rpm -ev proftpd) and reinstalling (rpm -ivh proftpd) it to make sure it loaded the proper pam modules and such.

    It could also be complaining about the lax security settings you have on your /home directory too.

    Though, like the above poster mentioned, you're a pretty daring person allowing full permissions to everyone on your server to fully write into the /home dir. Change /home to 775 and make sure you're setting the right default adduser prefs when creating the accounts.

    'useradd -m [user]' sets the proper user directory inside /home assuming your adduser default prefs has your HOME dir set up as /home.

    If those fail, try copying and pasting your /etc/proftpd.conf file so that we can attempt seeing if it's a configuration error.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •