Find the answer to your Linux question:
Results 1 to 3 of 3
We have been using 1280x1024 LCD monitors on all our computers, both Linux and Windows, with no trouble. Recently we got some widescreen LCDs, 1400x1050 and 1680x1050. They work fine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    8

    Unhappy Trouble with wide screens


    We have been using 1280x1024 LCD monitors on all our computers, both Linux and Windows, with no trouble. Recently we got some widescreen LCDs, 1400x1050 and 1680x1050. They work fine on Windows, but I'm having fits making them work with Linux. We use Red Hat Enterprise 4 or Scientific Linux 4, a clone of RHEL.

    The problems seem to be different with different hardware. I'll start off with the one that I have been able to work on the most. The video board is a Radeon X300 with 128 MB of memory. The monitor is a Viewsonic VG2230wm (1680x1050). The system-config-display application didn't offer 1680x1050 as one of the options, so I have tweaked xorg.conf by hand. I put in a Modeline for that resolution, and it seems to accept it. The Xorg log file doesn't show any errors, and 1680x1050 is listed as an acceptable resolution. The GNOME desktop is obviously stretched horizontally, and xdpyinfo says it's getting 1280x1024. It's odd that the monitor's Information menu says that it's receiving 1679x1049. Throwing in a "PanelSize" option has no effect. Removing all modes except 1680x1050 doesn't hel.

    Someone told me that Ubuntu handles this sort of thing better than Red Hat. So I made an Ubuntu boot disk to try it out. After a bit of confusion with the display-setting GUI, it worked perfectly. Full resolution was obtained with the proper aspect ratio. I'm not sure how it happened. Ubuntu used a device driver called "ati_drv" rather than "radeon". That was a disaster on Red Hat; X wouldn't start at all. The timing numbers were a bit different, but that doesn't change the behavior on Red Hat at all. However, this proves that there's no hardware problem.

    I have attached my xorg.conf and an abridged version of the Xorg log.
    ------------------------------------------------------
    The other machine I'm working on has an on-board Intel 745G graphics chip. There's a known problem with these -- the only available resolutions are the VESA standards hard-wired into the BIOS. There's a hack program called 915resolution which is designed to solve this problem. It kluges the BIOS to replace one of the resolutions with whatever you want. When I insert 1400x1050, it tells me that it worked. I do this on every boot before the X server starts (using rc.sysinit). It seems to have no effect. It puts out 1280x1024.
    Attached Files Attached Files

  2. #2
    Just Joined!
    Join Date
    May 2007
    Posts
    8

    Lightbulb One solved, one to go

    I should have known that posting here would help, even before any replies have arrived. I solved the first problem, the one with the Radeon. The problem was gconf. The attribute /desktop/gnome/screen/default/0/resolution was set to 1280x1050. I set it to 1680x1050 and the problem went away.

    Encouraged by this, I went to the other machine with the Intel graphics chip. That's still a stone wall. Its gconf setup doesn't have the "screen" branch. The best I could find is /desktop/gnome/peripherals/monitor/resolution_size. Changing it seems to have no effect.

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    8

    Solved, part deux!

    I made two changes on the Intel machine, and now it works. I removed every resolution except 1400x1050 from xorg.conf. I also added files by hand so that gconf has /desktop/gnome/screen/default/0/resolution. There's probably a better way to do it, but I had no clue what gconf does until yesterday.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •