Find the answer to your Linux question:
Results 1 to 3 of 3
I have installed Fedora 7 . It's starts fine but the update has dependencies that can,t be resolved. If I use yum -y upgrade or add-remove software I keep getting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Location
    Williamsville Vermont
    Posts
    14

    Unhappy Fedora 7 install dependency problems


    I have installed Fedora 7 . It's starts fine but the update has dependencies that can,t be resolved. If I use yum -y upgrade or add-remove software I keep getting this output.

    Error: Missing Dependency: libedataserver-1.2.so.7 is needed by package pidgin
    Error: Missing Dependency: libedataserver-1.2.so.7()(64bit) is needed by package pidgin
    Error: Unable to satisfy dependencies
    Error: Package pidgin needs libedataserver-1.2.so.7, this is not available.
    Error: Package mkinitrd needs nash = 5.1.19.0.3-1, this is not available.
    Error: Package pidgin needs libedataserver-1.2.so.7()(64bit), this is not available.
    Error: Package cyrus-sasl-plain needs cyrus-sasl-lib = 2.1.22-4, this is not available.
    Error: Package mkinitrd needs libparted-1.8.so.2, this is not available.

    Anyone know how to resolve this. Your help would be greatly appreciated.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    One relatively easy way to fix this is to remove whatever package "needs" the packages that are about to be upgraded/obsoleted and then reinstall that package after you have upgraded everything else. For example, remove pidgin, upgrade, then reinstall pidgin
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Two guesses
    1/ You may need to set up the repositories.
    2/ Maybe you need to install the development package from the installation cd.

    Please bear in mind that these are only guesses
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •