Find the answer to your Linux question:
Results 1 to 8 of 8
i mounted my ntfs file system successfully as root (read-only, redhat 9) but i am unable to see the content of it in my general user account.. the problem is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    3

    how to change permission to a read only file system


    i mounted my ntfs file system successfully as root (read-only, redhat 9)
    but i am unable to see the content of it in my general user account.. the problem is i want to use a software that will access the files..

    so pls if anyone can suggest either:
    - to change the permission cause chmod doesn't seem to work on read only file system even as root, or
    - how to run the user program with root priveleges

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Try this:

    Code:
    mount -t ntfs -o user /dev/hd* /mnt/whatever
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Posts
    3

    thanks

    thanks for the help

    mount -t ntfs -o uid=501 /dev/hda1 /mnt/windows worked for me..

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2005
    Location
    Pennsyltucky
    Posts
    1

    You can access mountpoints...

    Which Distro are you using? If you are using Mandrake like me, you can access the mountpoints applet in the control center. Displayed there are your hda/hdb etc drives. Your NTFS partition as you said HDA1 tab will have an expert or advanced mode button. What will now apear is an options button above the mount/unmount button. Click the options button and a new tab will show check boxes. Uncheck "Mount File System as READ-ONLY"

    If anyothers apply, check or uncheck. be mindfull of what you are doing. If you don't know, don't mess with it till you become familiar with it.

  6. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9

    Re: how to change permission to a read only file system

    Quote Originally Posted by icethunder
    i mounted my ntfs file system successfully as root (read-only, redhat 9)
    Hi icethunder,
    Will you please help me out to mount the NTFS partition into my Linux?
    What are the ways you followed to mount it?

    Thanx!

  7. #6
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1

    can't see NTFS mount as a user

    Quote Originally Posted by icethunder
    i mounted my ntfs file system successfully as root (read-only, redhat 9)
    but i am unable to see the content of it in my general user account.. the problem is i want to use a software that will access the files..

    so pls if anyone can suggest either:
    - to change the permission cause chmod doesn't seem to work on read only file system even as root, or
    - how to run the user program with root priveleges
    I had the same problem and what worked for me was adding umask=022 in the mounting options (/etc/fstab). After that all worked like a charm...

  8. #7
    Just Joined!
    Join Date
    Sep 2007
    Posts
    5

    Hello...

    Quote Originally Posted by syosef View Post
    I had the same problem and what worked for me was adding umask=022 in the mounting options (/etc/fstab). After that all worked like a charm...
    hello dear,
    i added a line that u mentioned in /etc/fstab as shown in below.
    /dev/hda3 /root/Drive_C ntfs rw,umask=022 0 0

    Then I mounted and entered into mounted directory and tried to write a file...

    [root@aung4 ~]# mount -a
    [root@aung4 ~]# cd Drive_C/
    [root@aung4 Drive_C]# cat > aung
    -bash: aung: Read-only file system
    [root@aung4 Drive_C]#

    I get an error as shown in above. Can you advise me please ? Thank you...

  9. #8
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums, aung_phyo

    Please start a new thread for your computer problem because this one is over 3 years old and too old to be bringing back to the top.

    Sorry for any inconvenience...

    oz
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •