Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Just installed Fedora7 on Compaq Presario 2100. Clean install-erased existing drv. I installed all default options on DVD including Office Productivity and Development Libraries, assigned a root password. Rebooted. Kernel ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! dleunen@marktwain.net's Avatar
    Join Date
    Jul 2007
    Location
    Missouri
    Posts
    8

    localhost login error


    Just installed Fedora7 on Compaq Presario 2100. Clean install-erased existing drv. I installed all default options on DVD including Office Productivity and Development Libraries, assigned a root password. Rebooted.
    Kernel 2.6.21-1.3194.fc7 on an i686

    error:
    localhost login: usb 1-2.4: can't restore configuration #1 (error=-71)

    rebooted:
    Startup
    audit-FAILED (All others OK)

    localhost login:

    I cannot get beyond this query for login. I have tried the root password and it will not accept that. I was never given an opportunity to set up a user or login password during install. How do I proceed here?

    I am probably way over my head with this OS, but hey! that is how you learn!

  2. #2
    Linux User DOllaBillz217's Avatar
    Join Date
    Mar 2007
    Location
    St. Louis, MO
    Posts
    263
    I'd either change my run level to 3 in the /etc/inittab folder so you boot straight to GUI and try to log in there and then you can reconfigure your users, or boot into single user mode. I know you can at least get to single user mode and then check out the user prefs from there. If you dont know how to get to single user mode, one bootup when it shows the kernel screen to select a kernel or wait for a certain amount of time, hit E for edit, go down one line and press E again, type single at the end of the line and then press B for boot.
    $Billz

    How much wood would a wood chuck chuck if a wood chuck could chuck wood? None they eat plants!

    Dell Optiplex GX260, LTSP Diskless Workstation, Fedora Core 6

  3. #3
    Just Joined! dleunen@marktwain.net's Avatar
    Join Date
    Jul 2007
    Location
    Missouri
    Posts
    8
    I can boot to the GNU GRUB screen before booting to the kernel. There are three entries:

    root (hd0,0)e
    kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00 rh
    initrd /initrd-2.6.21-1.3194.fc7.img

    If I try to edit "kernel" it opens the next screen with the following entry:

    </LogVol100 rhgb quiet

    I don't believe this is what I am supposed to edit...

    I have no graphical interface. I have not seen a welcome screen yet. I am in text mode and still trying to complete the first boot since install. I am hung at the localhost login query. Installation progressed in text mode after stating that the computer did not have enough memory. It is a Presario 2100 with 512 RAM, Intel Celeron and was running XP-that should be sufficient!

    I installed from a DVD. I tested the disc. I have actually done two complete installs with the same outcome. I had reformatted/repartitioned the drive and removed WINXP. Created a new boot loader (GRUB). Removed all partitions on drive and created default layout. I have not completed the first boot so I have not launched the setup agent.

    What is the localhost login? At what time in the install is this created?

    Why don't I have graphics? What can I do to get the graphical install?

  4. #4
    Linux User DOllaBillz217's Avatar
    Join Date
    Mar 2007
    Location
    St. Louis, MO
    Posts
    263
    "Localhost" refers to the local computer that a program is running on. For example, if you are running a Web browser on your computer, your computer is considered to be the "localhost." While this does not need to be specified when using a single computer, the localhost does need to be defined when running programs from multiple computers. For example, a network administrator might use his local machine to start a Web server on one system and use a remote access program on another. These programs would run from computers other than the localhost. However, the graphical install should not make a difference because it does the exact same thing wether its in text mode or graphical. And yes you are at the right spot for the editing, where it says "quiet" put a space and then type single and then press b for boot. This will allow you to access single user mode. From there you can go to your /etc/inittab and change the default run level from 3 to 5. Run level 3 is the default mode for text or command line and run level 5 is the default for your GUI interface. Try this and see if it gets you that GUI. and yes 512 should be more than enough memory to run a GUI because I do it with 128mb, but I am also running LTSP (diskless workstations) so the server handles most of the processes and overhead involved with memory. If this doesnt work let me know and I'll try to come up with a better solution for you.
    $Billz

    How much wood would a wood chuck chuck if a wood chuck could chuck wood? None they eat plants!

    Dell Optiplex GX260, LTSP Diskless Workstation, Fedora Core 6

  5. #5
    Just Joined! dleunen@marktwain.net's Avatar
    Join Date
    Jul 2007
    Location
    Missouri
    Posts
    8
    Now, after I boot, it executes startup to the point where this is displayed:
    sh-3.2#_
    I typed in the file command: /etc/inittab
    and received the response: Permission denied

  6. #6
    Linux User DOllaBillz217's Avatar
    Join Date
    Mar 2007
    Location
    St. Louis, MO
    Posts
    263
    Your at the right point but you must enter vi /etc/inittab so you can edit that file. Once the file appears you will see a default run level towards the top. If its equal to 3 the command line will appear, if its 5 then it will be set up for gui
    $Billz

    How much wood would a wood chuck chuck if a wood chuck could chuck wood? None they eat plants!

    Dell Optiplex GX260, LTSP Diskless Workstation, Fedora Core 6

  7. #7
    Just Joined! dleunen@marktwain.net's Avatar
    Join Date
    Jul 2007
    Location
    Missouri
    Posts
    8

    Defaul Level

    Followed your instructions. The inittab file displayed the Default runlevel:
    0-halt
    1-Single user
    2-Multiuser, without NFS
    3-Full multiuser
    4-unused
    5-X11
    6-reboot

    id:3:initdefault:

    # System initialization.
    si::sysinit:/etc?rc.d/rc.sysinit

    l0:0:wait:/etc/rc.d/rc 0
    l1:1:wait:/etc/rc.d/rc 1
    "/etc/inittab" 53L, 1666C

  8. #8
    Linux User DOllaBillz217's Avatar
    Join Date
    Mar 2007
    Location
    St. Louis, MO
    Posts
    263
    You have one of two options here now. You can either mess with the default run level to see if you can get it to boot to your preferred login screen. Once at the command line login screen (no gui) you should be able to log in as root and then change the password for whatever user you dont know the password for, or you can stay in single user mode at change the password from there. Let me know how this goes
    $Billz

    How much wood would a wood chuck chuck if a wood chuck could chuck wood? None they eat plants!

    Dell Optiplex GX260, LTSP Diskless Workstation, Fedora Core 6

  9. #9
    Just Joined! dleunen@marktwain.net's Avatar
    Join Date
    Jul 2007
    Location
    Missouri
    Posts
    8

    Defaul Level

    Ok.....don't forget, I am ignorant on this end!

    Not sure what to edit or where....

    I do have --INSERT-- below the last entry. How do I edit the default level and do I reboot or what after the entry?

  10. #10
    Linux User DOllaBillz217's Avatar
    Join Date
    Mar 2007
    Location
    St. Louis, MO
    Posts
    263
    Well judging by your output posted you are already in default runlevel 3 hince the

    id:3:initdefault

    which means you are already using command line, not a GUI during startup. If you do not come to a command line login screen witht he default run level three then I would say that my suggestion to edit the inittab file is not going to work because its already at run level three. My next suggestion would be to enter single user mode, or login as root if able to, and create you a new user by issuing the useradd command and you can then create a user and password which you know and login as this user. That would be my next step. Let me know if this works. And to get out of the /etc/inittab file hit Esa key, then type :q! to quit without saving any changes.
    $Billz

    How much wood would a wood chuck chuck if a wood chuck could chuck wood? None they eat plants!

    Dell Optiplex GX260, LTSP Diskless Workstation, Fedora Core 6

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •