Hi all,
I am facing a problem in launching mozilla browser from a program which is running through a service.I have a java program which opens a port and launches the mozilla browser from the terminal or CUI mode. When I run this program through a shell script everything works fine and the browser is easily started but when I tried to run the same program from a service, it created the port but did not launch the browser.That means the service was running fine but still it could not launch the browser due to some unknown reason. Just to check the things I executed the runmozilla.sh from the service it gave an error as "GTK WARNING : Cannot open display" but the same command ran successfully to launch the browser when I tried it from the terminal.I am working on a Redhat Linux 8.0 and an RHEL 4, I need to create a service or something similar so that the task can be accomplished automatically at boot time or after the GUI is loaded and my application continues to run in background, I am stuck with this therefore pls suggest some solution.