Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11

    repair linux


    I would recommend using a knoppix boot dvd /cd
    login as root
    repair system as needed.

  2. #12
    Quote Originally Posted by ceramicbrad
    I would recommend using a knoppix boot dvd /cd
    login as root
    repair system as needed.
    Don't respond with useless personal preference crap. At this point that solution has already been discussed, I'm having the same problem in that using physical media is not an option for me.

    Does anyone know how to enable write mode in the repair filesystem shell?

  3. #13
    Quote Originally Posted by icurtis
    Pythagoras,
    The original poster's point is that what you are suggesting can't be done.

    I've got exactly the same problem and I've even tried typing:
    "mount -f -rw /"
    This seems to return successfully but when I try a command like:
    "touch fred"
    I still get the error "cannot touch 'fred': Read-only filesystem"
    I've been having the same problem but luckily knew I had managed this a few years back. Google brought me to here. Anyway, one 'man mount' later:

    The -f in your mount command is the 'fake' option. So, the command doesn't actually do it.

    mount -w -o remount /

    is what you need.

  4. $spacer_open
    $spacer_close
  5. #14
    Quote Originally Posted by scrumpydude
    I've been having the same problem but luckily knew I had managed this a few years back. Google brought me to here. Anyway, one 'man mount' later:

    The -f in your mount command is the 'fake' option. So, the command doesn't actually do it.

    mount -w -o remount /

    is what you need.
    same problem... fixed now

    Thankyou, you are awesome!

  6. #15
    -->
    Quote Originally Posted by scrumpydude View Post
    I've been having the same problem but luckily knew I had managed this a few years back. Google brought me to here. Anyway, one 'man mount' later:

    The -f in your mount command is the 'fake' option. So, the command doesn't actually do it.

    mount -w -o remount /

    is what you need.
    thank you, this worked like a charm. But the / was mounted rw even before remouting it. I don't get it.... but it works anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •